VBox Additions

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Sof_T
Posts: 140
Joined: Fri May 01, 2009 4:46 pm

VBox Additions

Post by Sof_T » Thu Mar 03, 2011 11:58 am

For a long while I have been trying to install VBox Additions each time I tested a new release or a new trunk build. The result was always the same, on reboot the menu and window colours were messed up and more seriously ROS would crash whenever I tried to navigate the menus or run programs.

I'm not sure which build fixed it, but this mornings trunk I installed the VBox Additions, on reboot the colours are still strange, but ROS no longer crashes which means I can move my mouse outside VBox without needing to uncapture it.

Setting the screen properties to higher than 256 bits solved the strange colouring, but the icons still looked coloured by 256 bits. A final reboot solved that issue.

Techno Mage
Posts: 89
Joined: Mon Nov 28, 2005 2:05 pm

Re: VBox Additions

Post by Techno Mage » Thu Mar 03, 2011 1:02 pm

What build did you test, as i am yet to get one to install.
Apart from the graphical glitches all over the place.
I have had it freeze on copying files "mshtml.dll", or just BSOD
and it seem VT makes no difference

bugboy
Developer
Posts: 39
Joined: Thu May 22, 2008 9:23 pm

Re: VBox Additions

Post by bugboy » Thu Mar 03, 2011 2:40 pm

Techno Mage,
what version of vbox you using?
Image

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: VBox Additions

Post by Haos » Thu Mar 03, 2011 4:52 pm

What revision did you precisely tried? I used guest addons on both vbox 3.x and 4.x, all working fine.

Techno Mage
Posts: 89
Joined: Mon Nov 28, 2005 2:05 pm

Re: VBox Additions

Post by Techno Mage » Fri Mar 04, 2011 3:10 pm

When I said
What build did you test, as i am yet to get one to install.
That meant that ReactOS does not install.

Sof_T
Posts: 140
Joined: Fri May 01, 2009 4:46 pm

Re: VBox Additions

Post by Sof_T » Fri Mar 04, 2011 3:46 pm

Sorry for the late reply

ReactOS build 50960
VBox version 3.2.12

Techno Mage
Posts: 89
Joined: Mon Nov 28, 2005 2:05 pm

Re: VBox Additions

Post by Techno Mage » Fri Mar 04, 2011 4:09 pm

Hmm thats the same build I tried
But with VBox 4.0.4
And could not install ReactOS (With VT On or Off)

Did you have VT on or off?

Sof_T
Posts: 140
Joined: Fri May 01, 2009 4:46 pm

Re: VBox Additions

Post by Sof_T » Fri Mar 04, 2011 10:31 pm

VT is on, I've upgraded to the new VBox and ROS still works. One benefit of the upgrade is that ROS works better. Before Firefox used to load one page then would refuse to load any links from that page. After the upgrade Firefox now works, no change to the ROS install.

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: VBox Additions

Post by Haos » Sat Mar 05, 2011 3:24 pm

@Sof_T

What cpu do you have? Could you paste your ROS virtual machine config so we can take a look at it?

Sof_T
Posts: 140
Joined: Fri May 01, 2009 4:46 pm

Re: VBox Additions

Post by Sof_T » Sat Mar 05, 2011 3:33 pm

Is there an easy way to get the config settings in human readable form? I'm copy and pasting the xml config file since I can't see a way to attach it. My CPU is Pentium Dual Core E5200 2.50Ghz

Code: Select all

<?xml version="1.0"?>
<VirtualBox xmlns="http://www.innotek.de/VirtualBox-settings" version="1.9-windows">
  <Machine uuid="{ee67b22f-60f5-4d92-8f62-f83191f3fce1}" name="Pure Ros" OSType="WindowsXP" currentSnapshot="{c068e057-08e1-4d9a-a991-cd1b8ca16ad2}" snapshotFolder="Snapshots" lastStateChange="2011-03-04T21:38:39Z">
    <ExtraData>
      <ExtraDataItem name="GUI/LastCloseAction" value="powerOff"/>
      <ExtraDataItem name="GUI/LastGuestSizeHint" value="1280,960"/>
      <ExtraDataItem name="GUI/LastNormalWindowPosition" value="632,39,1280,1003"/>
      <ExtraDataItem name="GUI/LastWindowPostion" value="632,39,720,443"/>
      <ExtraDataItem name="GUI/MiniToolBarAlignment" value="bottom"/>
      <ExtraDataItem name="GUI/MiniToolBarAutoHide" value="on"/>
      <ExtraDataItem name="GUI/SaveMountedAtRuntime" value="yes"/>
      <ExtraDataItem name="GUI/ShowMiniToolBar" value="yes"/>
    </ExtraData>
    <Snapshot uuid="{c068e057-08e1-4d9a-a991-cd1b8ca16ad2}" name="Pre-tool install" timeStamp="2011-03-03T09:50:44Z" stateFile="Snapshots/{c068e057-08e1-4d9a-a991-cd1b8ca16ad2}.sav">
      <Hardware version="2">
        <CPU count="1">
          <HardwareVirtEx enabled="true" exclusive="false"/>
          <HardwareVirtExNestedPaging enabled="true"/>
          <HardwareVirtExVPID enabled="true"/>
          <PAE enabled="true"/>
          <HardwareVirtExLargePages enabled="false"/>
          <HardwareVirtForce enabled="false"/>
        </CPU>
        <Memory RAMSize="192"/>
        <Boot>
          <Order position="1" device="Floppy"/>
          <Order position="2" device="DVD"/>
          <Order position="3" device="HardDisk"/>
          <Order position="4" device="None"/>
        </Boot>
        <Display VRAMSize="18" monitorCount="1" accelerate3D="false" accelerate2DVideo="false"/>
        <RemoteDisplay enabled="false" port="3389" authType="Null" authTimeout="5000"/>
        <BIOS>
          <ACPI enabled="true"/>
          <IOAPIC enabled="false"/>
          <Logo fadeIn="true" fadeOut="true" displayTime="0"/>
          <BootMenu mode="MessageAndMenu"/>
          <TimeOffset value="0"/>
          <PXEDebug enabled="false"/>
        </BIOS>
        <USBController enabled="false" enabledEhci="true"/>
        <Network>
          <Adapter slot="0" enabled="true" MACAddress="080027F9C476" cable="true" speed="0" type="Am79C973">
            <NAT/>
          </Adapter>
          <Adapter slot="1" enabled="false" MACAddress="0800272A657F" cable="true" speed="0" type="Am79C973"/>
          <Adapter slot="2" enabled="false" MACAddress="080027711002" cable="true" speed="0" type="Am79C973"/>
          <Adapter slot="3" enabled="false" MACAddress="0800270EC21C" cable="true" speed="0" type="Am79C973"/>
          <Adapter slot="4" enabled="false" MACAddress="08002714D0D3" cable="true" speed="0" type="Am79C973"/>
          <Adapter slot="5" enabled="false" MACAddress="080027010621" cable="true" speed="0" type="Am79C973"/>
          <Adapter slot="6" enabled="false" MACAddress="080027D4CC4C" cable="true" speed="0" type="Am79C973"/>
          <Adapter slot="7" enabled="false" MACAddress="080027795A90" cable="true" speed="0" type="Am79C973"/>
        </Network>
        <UART>
          <Port slot="0" enabled="true" IOBase="0x3f8" IRQ="4" path="COM4" hostMode="HostDevice"/>
          <Port slot="1" enabled="false" IOBase="0x3f8" IRQ="4" hostMode="Disconnected"/>
        </UART>
        <LPT>
          <Port slot="0" enabled="false" IOBase="0x378" IRQ="4"/>
          <Port slot="1" enabled="false" IOBase="0x378" IRQ="4"/>
        </LPT>
        <AudioAdapter controller="AC97" driver="DirectSound" enabled="true"/>
        <SharedFolders/>
        <Clipboard mode="Bidirectional"/>
        <Guest memoryBalloonSize="0"/>
        <GuestProperties>
          <GuestProperty name="/VirtualBox/HostInfo/GUI/LanguageID" value="en_US" timestamp="1299141882992000000" flags=""/>
        </GuestProperties>
      </Hardware>
      <StorageControllers>
        <StorageController name="IDE Controller" type="PIIX4" PortCount="2">
          <AttachedDevice type="HardDisk" port="0" device="0">
            <Image uuid="{6358220d-3c2f-4f21-9df2-b09c03c5a781}"/>
          </AttachedDevice>
          <AttachedDevice passthrough="false" type="DVD" port="1" device="0">
            <Image uuid="{273c92ab-93df-491f-8cbb-e4a092334aa4}"/>
          </AttachedDevice>
        </StorageController>
        <StorageController name="Floppy Controller" type="I82078" PortCount="1">
          <AttachedDevice type="Floppy" port="0" device="0"/>
        </StorageController>
      </StorageControllers>
    </Snapshot>
    <Hardware version="2">
      <CPU count="1">
        <HardwareVirtEx enabled="true" exclusive="false"/>
        <HardwareVirtExNestedPaging enabled="true"/>
        <HardwareVirtExVPID enabled="true"/>
        <PAE enabled="true"/>
        <HardwareVirtExLargePages enabled="false"/>
        <HardwareVirtForce enabled="false"/>
      </CPU>
      <Memory RAMSize="192"/>
      <Boot>
        <Order position="1" device="Floppy"/>
        <Order position="2" device="DVD"/>
        <Order position="3" device="HardDisk"/>
        <Order position="4" device="None"/>
      </Boot>
      <Display VRAMSize="18" monitorCount="1" accelerate3D="false" accelerate2DVideo="false"/>
      <RemoteDisplay enabled="false" port="3389" authType="Null" authTimeout="5000"/>
      <BIOS>
        <ACPI enabled="true"/>
        <IOAPIC enabled="false"/>
        <Logo fadeIn="true" fadeOut="true" displayTime="0"/>
        <BootMenu mode="MessageAndMenu"/>
        <TimeOffset value="0"/>
        <PXEDebug enabled="false"/>
      </BIOS>
      <USBController enabled="false" enabledEhci="true"/>
      <Network>
        <Adapter slot="0" enabled="true" MACAddress="080027F9C476" cable="true" speed="0" type="Am79C973">
          <NAT/>
        </Adapter>
        <Adapter slot="1" enabled="false" MACAddress="0800272A657F" cable="true" speed="0" type="Am79C973"/>
        <Adapter slot="2" enabled="false" MACAddress="080027711002" cable="true" speed="0" type="Am79C973"/>
        <Adapter slot="3" enabled="false" MACAddress="0800270EC21C" cable="true" speed="0" type="Am79C973"/>
        <Adapter slot="4" enabled="false" MACAddress="08002714D0D3" cable="true" speed="0" type="Am79C973"/>
        <Adapter slot="5" enabled="false" MACAddress="080027010621" cable="true" speed="0" type="Am79C973"/>
        <Adapter slot="6" enabled="false" MACAddress="080027D4CC4C" cable="true" speed="0" type="Am79C973"/>
        <Adapter slot="7" enabled="false" MACAddress="080027795A90" cable="true" speed="0" type="Am79C973"/>
      </Network>
      <UART>
        <Port slot="0" enabled="true" IOBase="0x3f8" IRQ="4" path="COM4" hostMode="HostDevice"/>
        <Port slot="1" enabled="false" IOBase="0x3f8" IRQ="4" hostMode="Disconnected"/>
      </UART>
      <LPT>
        <Port slot="0" enabled="false" IOBase="0x378" IRQ="4"/>
        <Port slot="1" enabled="false" IOBase="0x378" IRQ="4"/>
      </LPT>
      <AudioAdapter controller="AC97" driver="DirectSound" enabled="true"/>
      <SharedFolders/>
      <Clipboard mode="Bidirectional"/>
      <Guest memoryBalloonSize="0"/>
      <GuestProperties>
        <GuestProperty name="/VirtualBox/HostInfo/GUI/LanguageID" value="en_US" timestamp="1299141882992000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/OS/Product" value="Windows 2003" timestamp="1299274398784000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/OS/Release" value="5.2.3790" timestamp="1299274398856000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/OS/Version" value="" timestamp="1299274398944000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/OS/ServicePack" value="1" timestamp="1299274399042000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Version" value="3.2.12" timestamp="1299274399146000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Revision" value="68302" timestamp="1299274399213000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/InstallDir" value="C:/Program Files/Oracle/VirtualBox Guest Additions" timestamp="1299274399245000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxControl.exe" value="3.2.12r68302" timestamp="1299274399346000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxHook.dll" value="3.2.12r68302" timestamp="1299274399377000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxDisp.dll" value="3.2.12r68302" timestamp="1299274399474000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxMRXNP.dll" value="3.2.12r68302" timestamp="1299274399569000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxService.exe" value="3.2.12r68302" timestamp="1299274399651000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxTray.exe" value="3.2.12r68302" timestamp="1299274399727000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxGINA.dll" value="-" timestamp="1299274399771000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxCredProv.dll" value="-" timestamp="1299274399832000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxOGLarrayspu.dll" value="3.2.12r68302" timestamp="1299274399946000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxOGLcrutil.dll" value="3.2.12r68302" timestamp="1299274399990000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxOGLerrorspu.dll" value="3.2.12r68302" timestamp="1299274400183000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxOGLpackspu.dll" value="3.2.12r68302" timestamp="1299274400310000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxOGLpassthroughspu.dll" value="3.2.12r68302" timestamp="1299274400406000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxOGLfeedbackspu.dll" value="3.2.12r68302" timestamp="1299274400492000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxOGL.dll" value="3.2.12r68302" timestamp="1299274400534000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxGuest.sys" value="3.2.12r68302" timestamp="1299274400557000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxMouse.sys" value="3.2.12r68302" timestamp="1299274400576000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxSF.sys" value="3.2.12r68302" timestamp="1299274400597000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Components/VBoxVideo.sys" value="3.2.12r68302" timestamp="1299274400604000000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/HostVerLastChecked" value="4.0.4" timestamp="1299274416249000000" flags=""/>
      </GuestProperties>
    </Hardware>
    <StorageControllers>
      <StorageController name="IDE Controller" type="PIIX4" PortCount="2">
        <AttachedDevice type="HardDisk" port="0" device="0">
          <Image uuid="{0193b29e-6253-49ad-acfb-f204cff37792}"/>
        </AttachedDevice>
        <AttachedDevice passthrough="false" type="DVD" port="1" device="0">
          <Image uuid="{273c92ab-93df-491f-8cbb-e4a092334aa4}"/>
        </AttachedDevice>
      </StorageController>
      <StorageController name="Floppy Controller" type="I82078" PortCount="1">
        <AttachedDevice type="Floppy" port="0" device="0"/>
      </StorageController>
    </StorageControllers>
  </Machine>
</VirtualBox>
Last edited by Sof_T on Sat Mar 05, 2011 3:57 pm, edited 2 times in total.

Saibamen
Posts: 212
Joined: Mon Jul 19, 2010 11:19 am
Location: Poland
Contact:

Re: VBox Additions

Post by Saibamen » Sat Mar 05, 2011 3:52 pm

Code: Select all

 please!
ReactOS Forum Global Moderator
IT-Maniak.pl administrator

Sof_T
Posts: 140
Joined: Fri May 01, 2009 4:46 pm

Re: VBox Additions

Post by Sof_T » Sat Mar 05, 2011 3:58 pm

Saibamen wrote:

Code: Select all

 please![/quote]

Edited :)

Haos
Test Team
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am
Contact:

Re: VBox Additions

Post by Haos » Sat Mar 05, 2011 5:33 pm

Please test with PAE disabled. It was always causing issues, at least for me.

janl
Posts: 53
Joined: Thu Dec 16, 2010 10:26 pm

Re: VBox Additions

Post by janl » Sat Mar 05, 2011 6:32 pm

I have had it freeze on copying files "mshtml.dll"
I have this "mshtml.dll" problem too - on Virtual Box while "Registering components ..." runs. Once I tested ROS on real hardware there was with "mshtml.dll" message some dialog about downloading Gecko. On real hardware it is possible to skip.

wojo664
Posts: 320
Joined: Mon Jul 06, 2009 5:39 pm

Re: VBox Additions

Post by wojo664 » Sun Mar 06, 2011 1:03 pm

I'm confirming mshtml hang. I've installed ReactOS at school in VirtualBox (Oracle) on a dualcore cpu Host, and it has some graphic glitches in second stage wizard and it hangs on this file also. Strangely on my computer (one core) preOracle this does not happening.

Post Reply

Who is online

Users browsing this forum: cernodile, Majestic-12 [Bot] and 2 guests