Page 1 of 1

Load Freeldr from both NTLDR and Pure-DOS mode

Posted: Mon May 16, 2005 9:40 am
by f22_storm
We know Freeldr.sys can be loaded by Grub, or the NTLDR. But both of
the operation are complicated for some of us.

So, I try to make it simple to apply. The Avldr.exe is a 3in1 loader for
Freeldr/Grub/ISOEmu. Here the '3in1' I mean, althouth it is a single file,
it can be used in 3 modes:

- as a Windows GUI Program, desinged as an installer;
- as a DOS program;
- as one item of boot.ini

Here you can download the avldr.exe and try it: ;-)

A). At the Pure-Dos Mode:

A:\> avldr.exe , and press 'Enter'

> This method is just like the Grub.exe, ieldr.exe

B). On the Windows GUI:

Just double click the icon of avldr.exe, and the expected functions are:

> Grub md5 Encryption; ( not available in beta 1 )

> Assemble new version of loaded program, even the fdd-image file
( not available in beta 1 )

> Install itself to boot.ini;

> As the front GUI of Qemu, or Bochs;

C). As one item of boot.ini:

Very simple, just add a new line:

c:\avldr.exe="BOOT AVLDR"

Posted: Mon May 16, 2005 10:48 am
by GvG
Hmm, could be useful. Under what license do you intend to release?

Free for all

Posted: Tue May 17, 2005 1:28 pm
by f22_storm
This applet is designed for all of pc boot-lovers. ;-)

I'll add a license file to this applet package while the next beta

version avaible.

Here, we must put a freeldr.ini to c:\, and put avldr.exe to

c:\, too.

Wish this tool will help you. :D

Posted: Wed May 18, 2005 1:16 pm
by GvG
Since you're using FreeLdr, which is released under the GPL, please make sure that your license is compatible with this.

Posted: Thu May 19, 2005 3:08 am
by f22_storm

Yes, the Freeldr inside the Avldr.exe is under GPL, but I don't think

the Avldr.exe must be under the GPL. Here, Avldr.exe is a little applet

been designed for makeing Freeldr easier to use when user is not so familier

with the ReactOS or Freeldr; especially the Windows user. ;-)

In technical, Freeldr is included as binary(with 7z compressed) in

Avldr.exe, just like the Chinese Version which having Grub 0.95 inside.

So, we can say, the Avldr.exe is not based on the source code of any

Grub, Freeldr, or ISOEmu, it is just a loader of them, just like the form

that Grub load the Linux Kernel, the partition file, or the memdisk. ;)

- BTW, by using this 7z method, we can even make the grub as a BIOS componet

which is less than 64kb, and we've named it Grub4ROM( it is also has no any

license but free for all ).

But, I want to share this tool for all, it is free for all. ;-) Yes,

I may have little license in my mind; I'd like to say, sometime, we may use

BSD license instead of the GPL license.

Wish this tool may help you, and Enjoy!

Posted: Thu May 19, 2005 11:55 am
by mf
Well, since BSD is more lax than GPL, it's GPL-compatible. So you should be fine with that.

avldr "cannot find ntoskrnl.exe"

Posted: Thu May 19, 2005 10:25 pm
by steveh
I have meanwhile tested "avldr.exe" for booting reactos on a FAT32 partition on 2nd primary partition of first HDD, partition which also contains Win98.

So I can dual-boot reactos or win98 with avldr.

Unfortunately when booting reactos, freeldr reports me that it cannot find "ntoskrnl.exe", though i have verified that

- ntoskrnl is in c:\reactos\system32 (and i have even copied it into the root directory)
- the path for ntoskrnl is correctly written in freeldr.ini
- i have written the second primary partition as boot device for reactos, into freeldr.ini

So, what else could be wrong?

I have done my tests of avldr in DOS mode, after booting win98 to command prompt only.

If i try avldr in GUI mode inside win98, it crashes with a "...illegal operation..." message box in windows.

BSD license

Posted: Thu May 19, 2005 11:01 pm
by chorns
The BSD license without the advertising clause is GPL-compatible. The one with the advertising clause is not.
mf wrote:Well, since BSD is more lax than GPL, it's GPL-compatible. So you should be fine with that.

Posted: Fri May 20, 2005 4:13 am
by f22_storm
To steveh:______________________

The problem, "ntoskrnl.exe" is missing reported by Freeldr,

I think, is so strange. The version of Freeldr inside the Avldr is

2.0 which comeing from ReactOS 2.6. I'll try, and find out

what's the reason.

And the crushing of Avldr.exe on Win98, I'm sorry to say, I only

test this version on WinXP. Pro, and the UI need IE installed.

It seems that, Avldr.exe need more improvment for functionality,

so that it will be a more useful tool. ;-)

To chorns:______________________

The software's license, is widely used on our world :-), but,

all of them make a little limitations for the users, the developpers,

sometimes. My deving the avldr, the isoemu, or even improving the

Grub's functionanlity, are all done by personal interesting, and just

want to make these tools more easier to use, and more powerful.

Of course, someone may say, this is the tidal current. So,

we should catch up with it. Ehn, how about call this license

'The Private License', "TPL"?


avldr on win98 (2) 1024 cylinder limit?

Posted: Fri May 20, 2005 10:06 pm
by steveh

thank you for your infos

>and the UI need IE installed.

That's it!
I had exiled IE from my win98se for security reasons. So that may explain the avldr crash in GUI?

avldr crashing in GUI is no problem for me, because booting win98se in command-line only mode is is faster anyway. I don't like await the long win98 GUI boot sequence before starting reactos.

If avldr only did not have the ntoskrnl problem!

Other questions about the ntoskrnl problem:
Can you imagine that either the 1024 cylinder limit is guilty?
Or that avldr does not work with a primary partition other than the first, despite i adapted the freeldr.ini?

I tried avldr and reactos on win98 partition because i cannot do so on my win2000 partition which is NTFS.

Posted: Sat May 21, 2005 4:28 am
by f22_storm

> Here, the GUI part of Avldr.exe cannot load the ReactOS. It

currently is only an installer of Avldr.exe if you have boot.ini

on the boot pratition.

> I know that you have 2 primary partition, and having Win98

installed on the 2nd one. So, I want to know, when you boot

the Win98, how about the status of the 1st one? It is hidden?

At this version of avldr.exe, I'v hard coded for Freeldr to load

the freeldr.ini at (hd0,0). Of course, you've mentioned

" that avldr does not work with a primary partition other than the

first, despite i adapted the freeldr.ini? ", I think this maybe the

reason. ;-)

avldr in win98 - FINALLY WORKS in pure dos mode!

Posted: Sat May 21, 2005 11:45 am
by steveh
When i work in win98, then both primary NTFS partitions number 1 and 3 are hidden.
And i do not have boot.ini in win98, of course.
:idea: Should i create in win98 a "dummy" copy of the boot.ini from win2000, to have avldr install in win98?

:D update:
avldr and reactos finally work!
what i have done:
copy the win98 partition to an old spare HDD, as primary partition 1, and mount it in my unused old P1 PC. When booting reactos, it gone automatically into the setup process.
On that old PC, i could not further test reactos, because it seems that SERIAL MICE ARE NOT SUPPORTED (?).
Then i copied the win98 partition back onto the HDD of my current PC as partition 2 primary. And now it works, no more messages about missing ntoskrnl.exe, and no major problems due to 2nd partition.

Only rosexplorer gives from time to time some strange error message in a popup box.

Posted: Mon May 23, 2005 3:12 am
by f22_storm
Congratulations! ;-)

It works. :D

:arrow: Of course, I've found out that the GUI part of Avldr.exe has

a critical error - `Install...' isn't woke.

- :P