QEMU -hdb fat:[folder]

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
b4dc0d3r
Posts: 148
Joined: Fri Sep 28, 2007 1:17 am

QEMU -hdb fat:[folder]

Post by b4dc0d3r »

I have been using local folder as FAT folder since 0.3.3 release, using qemu 0.9.0. I notice the 0.3.5 release has the newest 0.9.1

This is what I have been using (have not renamed the folder):
qemu -L . -m 128 -hda ReactOS.vmdk -serial file:output.txt -hdb fat:D:\ReactOS-0.3.3-QEMU\filesys

qemu 0.9.1 gives the error about cannot open "D:ReactOS-0.3.3-QEMUfilesys" without the slashes. So I noticed the change log says something about slashes and tried:
D:/ReactOS-0.3.3-QEMU/filesys

Now ROS says "Unable to get filesystem of D:\" and there are related vfat debug errors.

Anyone had this, or workarounds? I notice -hdb fat: is not well documented for windows, and marginally for linux. I found out there is "-hdb fat:rw:" which might solve the problem of saving output to the local folder, that would be nice if it worked.

steveh
Posts: 271
Joined: Sat Dec 18, 2004 10:02 pm

questions

Post by steveh »

>QEMU -hdb fat:[folder]

my general questions:
Is this option possible for any other drive (hda, cdrom, fda, fdb)? or only for hdb
If this option is used for hda, where is then located the bootsector of the virtual drive hda?

@b4dc0d3r
Questions about the problem:
which windows version are you using? is any windows access to "D:\ReactOS-0.3.3-QEMU/filesys" active at the same time while running qemu, is a windows explorer window open for instance with D: selected? Maybe there is an access conflict? How is qemu supposed to handle/avoid simultaneous access conflicts with this option?
What size does your "D:" have, and is it fat16 or fat32?

Goplat
Developer
Posts: 6
Joined: Wed Oct 12, 2005 1:04 am

Re: QEMU -hdb fat:[folder]

Post by Goplat »

qemu 0.9.1 generates invalid FAT images - the size of the partition given in the MBR is smaller than the size given in the partition's boot sector. This was the commit that broke it

These problems have annoyed me too, so I compiled 0.9.1 using the old version of block-vvfat.c, and with the backslash code in vl.c commented out. http://rapidshare.com/files/127694044/q ... d.zip.html

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests