Page 1 of 3

Preview of 0.3.1

Posted: Wed Feb 21, 2007 10:34 pm
by Z98
First, I received permission from Fireball to do this.

I'm one of two release engineers for ROS, the other being Colin_Finck. There are three reason this is being put up. First, because the devs no longer do release candidates, and in the current state of 03.1, it is release candidate worthy. Second, because we're only waiting for a fix for the AMD64 issue before we have the final build. Compiling the changelog will take at least two weeks, but besides that, there are no major roadblocks to the release itself. And third, it's to get people to stop asking when we'll release 0.3.1. If you are so eager to play with it, here.

That said, there are a few things you should be aware of. First, those running on AMD64 systems may not be able to get it to work on real hardware. Second, trunk has been broken on VMWare for a few days now and that might or might not have also been merged into the 0.3.1 branch. I'd suggest Qemu if you want to test it in a virtualized environment. And finally, a lot of things worked in 0.3.0 and before because of hacks. A lot of those hacks have now been removed, but obviously not all have been fully implemented. If you do test this build, feel free to mention what programs don't install/run here. One program you don't need to mention is Firefox. We know Firefox 2.0 doesn't work. We also know why. That fix will have to come down the line.

Posted: Wed Feb 21, 2007 11:14 pm
by samwise52
Just to remaind everyone this isn't an official relase of any kind. Some kind users have decided to help out and compiled a nice iso and made it publicly available. That said.... YAY REACTOS 0.3.1!!!!!

Posted: Thu Feb 22, 2007 12:22 am
by Cristan
Cool stuff! Perhaps you could make a preloaded .zip with qemu? (maybe even put kqemu in the same archive since it's small and provides a significant speedup) I'ts very handy to make a quick test. And a tip: the in the default .bat used parameter "-M isapc" makes ReactOS not boot, so remove that one.

Also: after clicking start, it is stated that this version is 0.4 SVN. Perhaps you should change that into "0.3.1 preview"?

Posted: Thu Feb 22, 2007 12:28 am
by Z98
We'll do that for the actual release. I'm not going to for the preview and whether Colin wants to is up to him.

Posted: Fri Feb 23, 2007 9:28 am
by Kutter9
I just tried to run 0.3.1 with VirtualPC 2004...
Installation crashes when trying to format a partition. After reboot it shows that a new FAT partition has been made, but crashes when trying to install ReacOS. After another reboot I tried quick format and it worked -> succesfully installed ReactOS, but it crashes at the bootscreen...
Live CD also crashes at the bootscreen.

Posted: Fri Feb 23, 2007 1:27 pm
by EmuandCo
Thats because VPC 204 sucks. :-P It is one of the crappiest VMs out there. Try QMEU or if you really wanna use MS stuff VPC 2006.

Posted: Fri Feb 23, 2007 3:19 pm
by Radhad
You mean Virtual PC 2007 ;) It has been released some days ago and it is free.

Posted: Fri Feb 23, 2007 5:13 pm
by Carlo Bramix
EmuandCo wrote:Thats because VPC 204 sucks. :-P It is one of the crappiest VMs out there. Try QMEU or if you really wanna use MS stuff VPC 2006.
When I saw this thread, I tested it into QEMU and it doesn't work in the same way as described by Kutter9.
I don't know how much my opinion could be considered important, but I must really say that I don't like the new boot screen.
It's similar, too similar to the one used into XP.
I can't believe we can't do something a bit more original.
But this is just my opinion, of course.


Carlo Bramini.

Posted: Fri Feb 23, 2007 5:34 pm
by Tiansen
I have a computer only for ReactOS testing. I tried both LiveCD and ISO.

Both give me the same error:

An error occured in FreeLoader
Report this error........

Exception 06: INVALID OPCODE

Followed with registry info etc.

Why is that? 0.3.0 worked on that same computer.
On two other computers LiveCD starts ok, however it freezes during loading on both.

Posted: Fri Feb 23, 2007 5:40 pm
by Z98
We'll need more information than that to actually tell you what's wrong. Though if you're using an AMD64 processor, the current build will not work. Which I mentioned above.

Posted: Fri Feb 23, 2007 5:52 pm
by Tiansen
No it is AMD K6-2 500MHZ computer.

What do you need?
Registry information? All registries? If not, which one?

Posted: Fri Feb 23, 2007 6:02 pm
by Z98
The opcode error you mentioned suggests a problem in the assembly coding/compiling. The problem with AMD64 may extend to older models. The specific problem is in a piece of assembly code. As such, I'm not too surprised that problem arose. Also, there have been major kernel changes lately. Things will break. The code won't really start stabilizing until at least 0.4.x

Posted: Sat Feb 24, 2007 2:16 pm
by Atari
hey Z98, have a question you might be able to answer. I've been compiling the 0.31 branch and tried it out under qemu and it has worked fine except when I set ROS_LEAN_AND_MEAN. it compiles but the resulting livecd will not run under qemu (atleast). I thought that ROS_LEAN_AND_MEAN basically only stripped the symbol tables, is it doing something else that might explain why it won't work?

Posted: Sat Feb 24, 2007 10:59 pm
by Z98
Asked around on IRC and there may be hidden bugs related to removing debugging symbols. This may or may not apply to ROS_LEAN_AND_MEAN, but it would explain problems booting.

Posted: Sun Feb 25, 2007 10:19 am
by chrisv5
Is ReactOS supposed to run on real hardware or only in QEMU? To tell the truth, I tried this release candidate and previous SVN builds (talking about "live CD" only, do not want to brick my PCs) and so far none has ever managed to get far on any of my PCs (and I have plenty of PCs).

You guys still have a long, long way to go!