Playing around on actual hardware - 0.3.0-RC1

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Posts: 3
Joined: Thu Oct 06, 2005 2:51 pm

Playing around on actual hardware - 0.3.0-RC1

Post by martinultima »

Hope this is the right place to post this... anyway, I've got a spare machine lying around, so I figured I may as well play around with ReactOS, see how it performs on actual hardware as opposed to an emulator like QEMU, which is what I normally use. Not sure how useful this is but here's hoping that it helps somehow :)

  • Compaq DeskPro EP6000
  • Intel Pentium III-650MHz
  • 64MB PC133 SDRAM
  • 2GB WD Caviar IDE HDD
  • Matrox G450 16MB AGP
  • Compaq PCI audio, untested
  • Generic 10/100 Ethernet, PCI
Installed ReactOS 0.3.0-RC1 from CD-ROM, after wiping out existing disk partitions using Linux fdisk and blanking the MBR. Took a few tries to get it just right, but ended up using 510MB FAT for C:, with no other partitions. (Wouldn't boot from anything larger, so I figured I'd try the safe FAT16 max size.) Did all partitioning from ReactOS installer. Used default installation options for everything.

FreeLoader wouldn't install correctly to the MBR; said it was there, but when I tried booting it failed. Worked just fine booting from a floppy; used Linux fdformat on another machine (fdformat -n /dev/fd0u1440) and rest from ReactOS installer. Booted very quickly, got through initial setup without any problems. For some reason didn't list floppy drive in Explorer, but accessed just fine from command prompt. Also noticed that winefile seems to be the only program capable of reporting free disk space, somewhat weird. Oh well, minor inconvenience AFAIC.

Set up desktop at 800x600x32. Didn't want to do 1024x768 even if I specified in the installer, not sure if this is a hardware of software limitation (pretty sure the G450 can go much higher than that, although haven't used the machine for a while so not entirely sure). Very nice-looking desktop and fonts, much better than Windows.

Does not appear to work with my machine's generic Ethernet card. Attempted to install NETGEAR USB wireless adapter, but setup application would not load. Don't really need this machine online much, and I've already seen ReactOS's networking in QEMU anyway, so not a major problem for me.

Installed Firefox (, official Win32 binary) from CD. Installation went just fine, although would not start Firefox directly after installation. Worked just fine after a reboot. Actually ran very stable on my machine; had Firefox running on desktop 1, Notepad on desktop 2, and spent around 15 minutes or so designing a local Web page - c:\index.html - without a crash. Eventually shut the machine down manually after getting bored with it ;) Very impressed. It did crash a couple of times before, first when I was browsing c:\ as a directory and then when I was poking around in the options dialog - had to shut down and restart, task manager refused to kill it - but just pulling it up and accessing a local file directly was almost effortless.

Running very fast on this machine, too, much faster than what I've seen of Windows (haven't used it in a while myself, and none of my machines run it, but it's definitely faster than what little I have seen). Considerably faster than on my regular desktop - Celeron-700, 256MB, running Firefox/GTK+2 on Linux - as well. Definitely impressed by the speed.

InfoZip's "unzip" - their official Win32 binary - ran just fine from the command line. Used it to extract 1.1.5 installation files. Had to restart a few times because it kept running out of memory, not sure how well ReactOS does memory management yet, but otherwise it went great. OOo's installer started up, but wouldn't do anything else, eventually ended up deleting it.

Didn't really get to test OOo 2.0.3. The "installer" actually just extracted the real installation program to the desktop, and by then it had eaten away most of the disk space I had so ended up deleting. I think I may have tried to run the OOo setup program once, but it didn't work.

AbiWord installed, but would not start. Using version 2.2.9, official Win32 binary. Have not tested newer version; my Linux boxes all run 2.2.9 because the newer ones require GNOME, so wanted to have the same version on all my machines for consistency.

I also managed to find a copy of MS Works 2000, one of the versions with Word included. Attempted to install Word, but failed, saying I needed a newer Microsoft installer. MS Works really must be an oxymoron ;) Doesn't matter much to me, since I don't need any Microsoft stuff anyway, but might be an issue for other people.

Hot Wheels: Stunt Track Driver, a DirectX game from about 1998, would not install, claiming it was an "invalid executable format", and attempting to run directly from the CD resulted in it saying I didn't have the right DirectX version (it expects 6.0 or newer, included on CD). DirectX installer didn't want to work either.

WinZip 10.0's installer loaded, but failed because the latest Windows Help viewer wasn't available.

ReactOS's "ibrowser" loads just fine, but doesn't work without the Mozilla ActiveX control. Download window comes up, but closes because it doesn't have a net connection.

ReactOS Explorer works OK, but a bit quirky, and sometimes won't delete files/directories properly. Attempting to copy files from Explorer (drag&drop) crashes the machine.

Also have AVG AntiVirus, ZoneAlarm Personal, Thunderbird, and a few other programs; have not had an opportunity to test.

Anyway, just thought I should share, in case anyone finds this useful :)

Posts: 295
Joined: Mon Jun 13, 2005 12:16 pm

Post by GreyGhost »

Welcome to ReactOS ..!!
Very good feedback in my opinon ...!!

Some of those problema (bugs ) are indded known and will be fixed in the future...
And if u test apps. on 0.3 final release please submit test reports at the ReactOS support database here...,

NOTE: please make sure u submit reports for 0.3 final (when its released ) and not the RC or SVN builds....

Posts: 363
Joined: Sat Jan 01, 2005 3:18 pm
Location: Netherlands

Post by Elledan »

Quite a comprehensive review :)

It might be nice if people were to write more reviews like this, especially for the SVN versions. It'd give people (new to ROS) more insight into what this OS is like and might convince them to give it a go/recommend it to friends/etc.

Posts: 9
Joined: Tue Jul 25, 2006 2:00 am

Post by kopinux »

i also believed that working with real hardware is better than virtual emulators when helping develop the OS.

so i did, i have problems with my boot lately, so i just installed it in my existing windows xp, it co-existed nicely, though problems is because react share same c:\program files as my windows did, so i just installed it in a separate partition of 512mb fat32.

managed to install the network, sound and nvidia 71.89 windows driver.
though the sound (but detected) and nvidia does not work due to looking for some missing system files.

i installed DOSBox with it and played x-com. also i installed the latest firefox 1.6 but firefox closes if you do anything related to downloads.

i also posted my ethernet in the support compability database, but i messed up since i cant edit it or delete my entry, my mistake, the latest version in the selection is 2.9 i cant find how to select 3.0.

Posts: 496
Joined: Tue Dec 27, 2005 12:43 am

Post by Matthias »

kopinux wrote:i cant find how to select 3.0.
You can't, because 0.3.0 is currently only a RC and not a Release.

Posts: 300
Joined: Wed Mar 01, 2006 4:26 am

Post by Coviti »

Matthias wrote:
kopinux wrote:i cant find how to select 3.0.
You can't, because 0.3.0 is currently only a RC and not a Release.
You can checkout the 0.3.0 branch at [url]svn://[/url], or download the pre-built ISO from (Recommended).

Note: The SVN branch of 0.3.0 is newer than RC1, but not necessarily more stable.

Posts: 244
Joined: Wed Sep 13, 2006 1:34 pm
Location: north italy

Post by walter »

i have a spare hard disk and a secondary pc which i can use for testing. which version of reactos should i use?

after i've finished testing, i'll add a post in this discussion

Posts: 508
Joined: Mon Apr 25, 2005 12:46 pm

Post by ThePhysicist »

On real hardware you should try 0.3.0 final. SVN versions are pretty unstable at the moment. Latest revisions don't always boot on vm's and will probably not work on real hw.

Posts: 244
Joined: Wed Sep 13, 2006 1:34 pm
Location: north italy

Post by walter »

thanks for the info. i've already prepared the install cd, i think i'll try this week.

Posts: 244
Joined: Wed Sep 13, 2006 1:34 pm
Location: north italy

Post by walter »

i started trying something. just a few minutes, so results aren't very accurate.

here are the pc specs

- pentium 3 933 mhz
- ram 384 mb (3 * 128 mb, each row is different from the others but they work together without problems)
- motherboard msi ms 6039 lite (via chipset)
- integrated audio via vinyl
- video card 3dfx voodoo 3 3000 (if you want, i also have a matrox g 400 dual head and a geforce 4 ti 4200 to test)
- scsi controller adaptec 2940
- ethernet card d-link dfe tx530+ (i dont' remember exactly the name!)
- hard disk 4.7 gb (i think it's a fujitsu or something similar)
- dvd rw unit lite on sohw 1213s
- floppy drive

also, it has a strange card on the isa slot with a connector which looks similar to a parallel port, but it's larger. i didn't check what this is.

under Windows 98se and live linux distro (knoppix, mandrakemove, ubuntu), this pc works very well. in facts, under Windows it is incredibly stable with only a little tweaks. only, i use another hard disk, 8.7 gb (i removed it before putting on the spare one for saving my data)

so, i started playing. installation was very fast and went fine; only, after a reboot mouse didn't work. i don't know if this is a bug or just a mouse problem (it's a cheap model), i'll try again.

on the "local" selection of the second part, keyboard layout box didn't work while language box worked. i'll try again to see if this is also a mouse problem.

startup is incredibly fast, i have NEVER seen something nearly similar.

the default screen is very clean and easy to use. i didn't installed drivers using the wizard because i wanted to try setup programs. amigasport drivers setup completed successfully but at restart it still didn't use that video driver

i tried drag & drop and copy & paste and, as expected, these didn't work (i know this os is in pre alpha etc :wink: ). ros explorer sometimes looks very similar to windows 95 explorer. when i open a folder, it doesn't allow me to go back (i'll check this to see if it's just another mouse problem)

the command prompt: it worked quite well. it created a directory without problems, however when i tried copying some files into that directory, it closed unexpectedly. without being able to move/copy files, using a pc is not really user friendly.

for the rest, i have to say that (for a beta) the system looks quite stable and works without huge problems. i like it, i hope the next version is coming soon so that i can start using it more intensively.

i think i'll try again in the next days, and (if you like it, obviously) i'll post again my impressions. sorry for my bad english.

just my 2 cents.

edit: i was forgetting, i think setup should be changed so that reading the license is not "optional", but you have to pass on the license page like in windows or linux setup
Last edited by walter on Fri Sep 15, 2006 11:31 am, edited 1 time in total.

Posts: 244
Joined: Wed Sep 13, 2006 1:34 pm
Location: north italy

Post by walter »

i tried again this morning. keyboard layout in second part of setup doesn't work.

after i tried installing drivers with the driver install wizard (except only via 4 in 1)

via 4 in 1 didn't work
scsi card drivers refused to install (i'll have to try again)
network card d-link tx530+ drivers installed successfully
amigasport drivers didn't install; setup ended, but the last page said "driver could not be installed because an error happened"

after i tried playing with the task manager and i got a bsod. at the next reboot, the system didn't start (csm serverinitializationfailed or something similar). i tried reinstalling the system but it still didn't work. i'll have to format and try again.

also, little problem: "num lock" led on the keyboard doesnt' work

Posts: 10
Joined: Mon Jan 01, 2007 4:26 am

Post by Durel »

I have a few spare pcs, but most are relatively new (~ 2ghz >512MB ram)

Ill try installing reactos on a harddisk and moving it between pcs for fun. should be interesting to see how many drivers i can actually get to work but it might be a few days before ill be able to make a testdrive

Posts: 4
Joined: Sat Dec 24, 2005 12:28 am

Compaq Evo D510 with Reactos Live 0.3.0

Post by u101 »

I tried Reactos Live 0.3.0 on a Compaq Evo D510 (P IV 2.4Ghz, 256MB RAM, Intel 845G Chipset), and it worked. I did not do much testing, though.

Posts: 295
Joined: Mon Jun 13, 2005 12:16 pm

Post by GreyGhost »

u101 ,nice to hear that it works with ur hardware.. :)
maybe u can try a few of the inbuilt apps and see if it pops u any problems..
Regards GreyGhost

Posts: 4
Joined: Sat Dec 24, 2005 12:28 am

about Compaq Evo D510 with Reactos Live 0.3.0

Post by u101 »

GreyGhost wrote:u101 ,nice to hear that it works with ur hardware.. :)
maybe u can try a few of the inbuilt apps and see if it pops u any problems..
About Explorer: works (can browse, no crash), but has drawing errors (seems toolbar and other things are not always redrawn when needed).

What other apps ? (There are not that many on the live cd.)

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot], Bing [Bot], MadWolf and 4 guests