HW Test: Acer AspireOne (AOA150)

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
Posts: 4
Joined: Sun May 06, 2018 2:12 am

HW Test: Acer AspireOne (AOA150)

Post by irwazr »

Howdy all,

I'm doing a full hardware test, installing ReactOS 0.4.13 on an Acer AspireOne (AOA150) mini notebook. I used the ramboot method from Windows using Rufus and the Syslinux loader. This part of the process worked well, even if Rufus initially didn't have syslinux as an option (I think it had to download it in the background on first launch). I got the base OS built successfully, and all was looking good. I went to shut it down and then it hung on an empty background (blue background, no icons or taskbar) and never shuts down. On forcing a reset (hold power down) it now looks like ROS isn't detecting USB devices, as my mouse and USB stick aren't working.

Going to rebuild the OS again and see if getting the chipset drivers installed on first boot helps.

Will keep this project updated here for anyone interested.
Posts: 4
Joined: Sun May 06, 2018 2:12 am

Re: HW Test: Acer AspireOne (AOA150)

Post by irwazr »

Update: I can get 0.4.13 to install just fine, and everything seems to work well. However installing the official chipset or video drivers kills it on next boot. Tried installing them 1 at a time, so it wasn't because I rammed them in at the same time without boots between them.

I tried using the Snappy Driver Installer tool (full offline), but it kept bugging out on me. It would hang on "Extracting". I tried rebuilding the indexes, but saw no improvement. I thought it might be because I was running SDI from USB, but copying it locally also didn't help. I then extracted the full set of chipset drivers, rebuilt the indexes and it then hung on the installation just like it did on extractions previously.

I then cross checked all results on an old Lenovo ThinkPad T43, and got all of the exact same behaviour from SDI under 0.4.13. So I assume the issue is either the current release of ReactOS, or the current version of SDI... or a mix of box.
Posts: 3
Joined: Wed Jun 10, 2020 7:40 pm

Re: HW Test: Acer AspireOne (AOA150)

Post by easeltine »

I am trying this on my Acer Aspire One D250, w 2 GB RAM, from an External DVD-ROM drive.

I get nothing trying the Install CD, and get to the ReactOS start screen, and then a blue screen of death. I tried fooling around with the BIOS to no avail.

I have not tried installing ReactOS to my older Toshiba Laptops, I am using them successfully in the older Toshiba, with Linux ZorinOS Lite, (hint), as the Host, and ReactOS in the VirtualBox.
Posts: 4
Joined: Mon Oct 16, 2006 2:16 am

Re: HW Test: Acer AspireOne (AOA150)

Post by uncletom »

I found the same problems on my laptops; ACER Aspire, Toshiba Satellite, HP 2000, Lenova ThinkPad, Compaq 2100.
The CD boot winks/blinks/no messages,nothing... then the bios moves to the next device, which boots Linux, Win x, whatever.
Tried first Reactos back in 2006, and it sorta worked.
Jan.2017 version 0.4.3 would not boot.
Today, Jul.2020 version 4.13 would not boot. So, I tried the roll-your-own USB booter.
C'mon guys, this is not rocket science. I have a working Linux system on two-floppys !
"Now place bootcd.iso and/or livecd.iso in the root of the disk (or whatever path configured in freeldr.ini)"
What in ??? is that supposed to mean ? There is no "bootcd.iso and/or livecd.iso" on my systems.
I'll try again next year.
Posts: 6
Joined: Sun Apr 07, 2013 11:50 pm

Re: HW Test: Acer AspireOne (AOA150)

Post by extravert34 »

uncletom wrote: Sun Jul 12, 2020 1:41 am What in ??? is that supposed to mean ? There is no "bootcd.iso and/or livecd.iso" on my systems.
bootcd.iso and livecd.iso is what you download on https://reactos.org/download/ or https://reactos.org/getbuilds/ page
User avatar
Posts: 1640
Joined: Mon Jun 14, 2010 5:54 pm

Re: HW Test: Acer AspireOne (AOA150)

Post by dizt3mp3r »

Building an o/s from scratch actually is close to being Rocket Science, kernel programming being extremely complex, probably more so than building a Rocket. Whether or not you have a working Linux system is completely irrelevant as you are working with ReactOS, an Alpha grade o/s and you should NOT expect it to work.

If you are going to be install an o/s in Alpha you need to do more research (Google is your friend in this regard) and you need to become more familiar with the technologies.
Skillset: VMS sysadmin 20 years, fault Tolerance, cluster, Vax, Alpha, ftSparc. DCL, QB45, VB6, NET, PHP, JS, CMS, Graphics, Project Manager, DOS, Windows admin from 1985. Quad Electronics. Classic cars & motorbikes. Artist watercolours. Historian.
Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest