Installed ReactOS in KVM libvirt, solved hang

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
KenJackson
Posts: 12
Joined: Thu Sep 29, 2005 3:00 pm

Installed ReactOS in KVM libvirt, solved hang

Post by KenJackson »

When I tried to install Reactos v0.4.10 BootCD as I had done previously in a KVM virtual machine using libvirt on Linux, it would hang. But I got it to work.

Previously, I used the switch "--os-variant winxp" on the virt-install command line. But that hangs now. I tried winnt4.0 and winnt3.51 but they both fail to even boot the CD. But winnt3.5 works.

Here is the complete installation command that worked for me:

Code: Select all

sudo virt-install --name ReactOS --connect qemu:///system --virt-type kvm --vcpus 1 --os-variant winnt3.5 --memory 1024 --memorybacking nosharepages=true --disk path=/dev/vg0/ros,format=raw --cdrom '/extra/iso/ReactOS-0.4.10.iso' --network bridge=br0 --video vga --graphics vnc,port=5907,listen=0.0.0.0

KenJackson
Posts: 12
Joined: Thu Sep 29, 2005 3:00 pm

Re: Installed ReactOS in KVM libvirt, solved hang

Post by KenJackson »

It turns out that the failure of the CD to boot is independent of the "--os-variant" switch. When I reinstalled, it failed to boot again. Then I realized it's just intermittent. It fails, so press ENTER. If it fails again, I press ENTER again until it boots. It seems to fail about twice per installation.

Fortunately the CD is only needed during installation. It boots from the hard disk every time.

I reinstalled with "--os-variant winnt4.0". I can't tell any difference between any of those values. Except that "winxp" definitely won't work (it installs but won't boot).

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests