0.4.10 Testing

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
Heis Spiter
Posts: 183
Joined: Sun Sep 03, 2006 11:39 am
Location: Paris, France

0.4.10 Testing

Post by Heis Spiter » Sun Sep 02, 2018 11:09 pm

We have another release coming up! Please support us in testing for regressions.


Pierre Schweitzer (aka Heis Spiter)
ReactOS kernel developer.
ReactOS systems administrator.

Posts: 8
Joined: Thu Aug 23, 2018 9:48 pm

Re: 0.4.10 Testing

Post by win3x » Sun Sep 09, 2018 1:26 pm

install reactos to brtfs partition not work, i have bsod in first boot

Posts: 1489
Joined: Mon Jun 14, 2010 5:54 pm

Re: 0.4.10 Testing

Post by dizt3mp3r » Sun Sep 09, 2018 2:05 pm

Raise that as a separate post not here and/or as a bug on JIRA.
Skillset: VMS sysadmin 20 years, fault Tolerance, cluster, Vax, Alpha, ftSparc. DCL, QB45, VB6, NET, PHP, JS, CMS, Graphics, Project Manager, DOS, Windows admin from 1985. Quad Electronics. Classic cars & motorbikes. Artist watercolours. Historian.

Posts: 2
Joined: Wed Nov 21, 2018 3:26 pm

Re: 0.4.10 Testing

Post by cubiz » Wed Nov 21, 2018 3:34 pm

Do i need Rufus for burn reactos to the cdrom? Or another burn software (from linux) is good enough to boot with reactos?

Posts: 1
Joined: Thu Aug 18, 2016 5:17 pm

Re: 0.4.10 Testing

Post by nikko1960 » Wed Nov 28, 2018 7:55 pm

Hi all, installed 04.11.dev fae6853, on ASUS P5G41T-M LX, INTEL CORE 2 QUAD Q6600 4GB RAM HDD 160GB, the installation works fine, after reboot in rosdbg mode pc stop on HIDUSB.SYS.

Posts: 6
Joined: Sun Mar 27, 2016 4:00 am

Re: 0.4.10 Testing

Post by benqpolska » Wed Nov 28, 2018 9:17 pm

why mounting guest additions doesnt work? [livecd]
@nikko1960 its related to usb stack i think, you have another topic on this forum regarding to usb

Posts: 3
Joined: Wed Dec 05, 2018 12:36 am

Re: 0.4.10 Testing

Post by GreyGeek » Wed Dec 05, 2018 1:22 am

Hi everyone! I've been using Linux since RH5 in May of 1998. I have been using Kubuntu since Jan of 2009 and am currently running Kubuntu 18.04 on BTRFS, which I've used for almost 4 years and will never run Linux without it. I am using a 6-year-old Acer V3-771G with 16GB RAM, an i7 CPU and an NVidia GeForce GT 650M with 2GB RAM in the GPU. It has a 500GB SSD and two 750GB HDs. NVidia is the default on the Plasma5 desktop.

I recently purchased a handheld ECG unit (Heal Force Prince PC-80A, made in China) to replace the Kardia ECG iPhone ultrasonic device. It has a USB port and cable to upload data to a Windows system on which should be installed their ECG Viewer program. (You know where this is going! :D ) It turns out that even though the unit I have was made on June 4, 2018, the software that is downloadable from their website was written during the WinXP era. I first tried to install the software using WINE, but no joy. So, I tried PlayOnLinux next, but it wouldn't install the software either. The fundamental problem was that the InstallShield application inside Setup.exe had a bug that prevented it from running USBSetup.exe, and running USBSetup.exe with WINE didn't work without the environment established by Setup.exe. Catch-22, which is why both WINE and POL failed to install the "EASY ECG" software.

By luck I saw a post about the latest release of ReactOS and downloaded it, unaware of its USB problem. I first used VirtualBox. ReactOS installed just fine in VB but I couldn't see the EASY ECG connection via the USB port. So, I uninstalled VB and reverted to using qemu-kvm. ReactOS installed beautifully and runs well, sans USB. :( I was able to plug the Prince 180B into a USB port and Dolphin saw and and allowed me to browse the files in it, and copy them to my Kubuntu system. I was able to upload the data and the zip file of the EASY ECG program to my MEGA cloud account. In ReactOS I installed FF48, and immediately upgraded it to FF54. I was able to download the files from MEGA to my local ReactOS Download directory. EASY ECG installed without problems on ReactOS, but the USB connection is still invisible to the application. So close but still so far away.

I had tried ReactOS several years ago and couldn't even get it to boot, but now is installs easily and runs fairly well. There are some annoying bugs: The "X" doesn't reliably close a program. Neither does "Cancel" or "Quit". Using Delete puts a copy in the trashcan but doesn't remove the target. However, emptying the trashcan does work. A lot of functions in the control panel do not display anything in the right panel when an object in the tree in the left panel is clicked. Those are annoying nits but not critical. Sound and USB install failures are not nits, even after 10 years ...

All in all, though, ReactOS 0.4.10 is great and I am going to keep it around. A qemu-kvm install is drop-dead easy and much quicker than VB, and in qemu-kvm ReactOS appears to run much faster than in VB. So, reinstalling after every release will be easy. Getting BTRFS to work reliablly on ReactOS would be a bonus as far as backing up and restoring.

Keep up the good work, folks!

Posts: 4357
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld

Re: 0.4.10 Testing

Post by EmuandCo » Wed Dec 05, 2018 2:48 am

If you want to tinker with the new USB drivers a bit: http://vgal.ru.com/reactos-0-4-10-new-usb/
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot] and 4 guests