Wine Version change

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
start1119
Posts: 6
Joined: Sat Nov 26, 2016 10:54 am

Wine Version change

Post by start1119 »

Does user can be change the wine version ? like linux wine .
Try Reactos install software it is detect this is xp . can change detect to win7 or others?

User avatar
Konata
Posts: 391
Joined: Sun Apr 20, 2014 8:54 pm

Re: Wine Version change

Post by Konata »

WINE is just an API layer, the kernel is the one doing the work, and that doesn't currently support any version of WinAPI past Server 2003, so it wouldn't really do anything.

User avatar
Fraizeraust
Posts: 233
Joined: Thu Jan 05, 2017 11:46 am
Location: Italy
Contact:

Re: Wine Version change

Post by Fraizeraust »

WINE is deeply implemented in the ReactOS source code for Win32 and other stuff thus it's impossible to replace a WINE version with another like you would do in Linux distributions.

oldman
Posts: 1123
Joined: Sun Dec 20, 2009 1:23 pm

Re: Wine Version change

Post by oldman »

start1119 wrote:Does user can be change the wine version ? like linux wine .
Try Reactos install software it is detect this is xp . can change detect to win7 or others?
Is start1119 asking if he can change the version that ReactOS reports itself as? Which understand can be done, but I don't know how to do it; I think it is by altering some text in the Registry. But I don't think that will help much with software!

There is a shim engine which is turned off by default, which can be turned on, which should help software run, that is designed for newer Windows, but again I do not know much about it.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - ISO remaster.
They may help you with a problem, so do have a look at them.

User avatar
EmuandCo
Developer
Posts: 4423
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: Wine Version change

Post by EmuandCo »

Shim does not help you in any way to run software not working on XP/2003, YET. This will come soon, but needs quite some more work to be done, because the 5.X shim engine is not capable of that aka it needs to hop in way earlier to trick newer apps that all is fine.
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

erkinalp
Posts: 858
Joined: Sat Dec 20, 2008 5:55 pm

Re: Wine Version change

Post by erkinalp »

You can perfectly replace 5.X shim by 6.x shim or 10.0 shim or some other compatibility engine, because, application compatibility workarounds themselves are not meant to be worked around.
-uses Ubuntu+GNOME 3 GNU/Linux
-likes Free (as in freedom) and Open Source Detergents
-favors open source of Windows 10 under GPL2

User avatar
EmuandCo
Developer
Posts: 4423
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: Wine Version change

Post by EmuandCo »

If you claim any stuff, would you please add a proof from now on? My answer is from our devs fighting with shim, what about yours?!
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

erkinalp
Posts: 858
Joined: Sat Dec 20, 2008 5:55 pm

Re: Wine Version change

Post by erkinalp »

application compatibility workarounds themselves are not meant to be worked around.
has a computer theoretical and a practical background. First, the theoretical one: if you agreed on otherwise, each recursion would increase test case surface squarely(cases where workarounds of workarounds are applied need to be tested individually) and supporting unbounded recursion of compatibility workarounds means infinite number of test cases, i.e. untestable. Second, the practical one: Microsoft also has a similar stance on compatibility workarounds. You are on your own if you work around a compatibility workaround.
-uses Ubuntu+GNOME 3 GNU/Linux
-likes Free (as in freedom) and Open Source Detergents
-favors open source of Windows 10 under GPL2

petr-akhlamov
Posts: 59
Joined: Wed Apr 10, 2013 3:23 pm
Location: Russia, Moscow

Re: Wine Version change

Post by petr-akhlamov »

How i know, in ReactOS (as in Windows), APIs libraries are depend on kernel. Already Mark Jansen working on compatibility mode (which, will help run old apps), and also planned work on implementation of NT 6.x-comptability for NT5 kernel.

http://jira.reactos.org/browse/CORE-10366
http://jira.reactos.org/browse/CORE-11288
http://winehq.org.ru/Compatibility_mode - on russian

MadWolf
Posts: 559
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: Wine Version change

Post by MadWolf »

hi
i looks to me as the op is asking about compatibility mode https://support.microsoft.com/en-gb/hel ... compatible

on GNU/Linux some application need to be run using a specific version version of WINE

Post Reply

Who is online

Users browsing this forum: Semrush [Bot] and 2 guests