How to turn on networking?

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

Post Reply
SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

How to turn on networking?

Post by SomeGuy » Tue Dec 21, 2004 5:15 pm

I have read recently that networking is just starting to work somewhat. I wanted to kick it around so I tried enabling it on real hardware and in QEMU but got nowhere. (After specifying the IRQ and Port in the registry it would find the NE2000 compatible but then crash)

What is the needed setup to get it to run? Or should I just shut up and wait until it is finished? :)

Gedi

Re: How to turn on networking?

Post by Gedi » Tue Dec 21, 2004 7:02 pm

It should be a simple case of setting the IP values in the registry for your given card.

I'm not on react, or windows at the moment, but from memory I would say:

HKLM\system\currentcontrolset\services\{your card}\tcpip\parameters

Set your IP, default gateway and DNS server addresses.

You may need to bridge the network connection with your real card for emulated ROS.

SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Post by SomeGuy » Wed Dec 22, 2004 8:51 pm

Well, the problem I am having is not with the TCP/IP configuration, the NDIS driver isn't loading because it can't find my card. When I fed it the port and IRQ for my card debug output said it found the card and then crashed at startup. The card I am using is an ALN-201 PCI card. It is supposed to be NE2000 compatible. I'll try another one when I can.

Also, when using QEMU I already tried configuring the TCP/IP and that didn't help, it also looks like the NDIS driver is not loading. Since ReactOS is being distributed in QEMU I would kind of think it would be pre-configured to work in that environment.

SomeGuy
Posts: 586
Joined: Mon Nov 29, 2004 9:48 am
Location: Marietta, GA

Post by SomeGuy » Sun Dec 26, 2004 9:09 pm

I tried several other cards including an NE2000 compatible ISA known to be 100% NE2000 compatible, but still had the same problem, ReactOS crashes right after loading the NE2000 driver. I see now that running on real hardware is now a known issue.

Is the NE2000 emulation in QEMU supposed to work with ReactOS? (the ROS QEMU images are not configured for it)

Jaix
Moderator Team
Posts: 838
Joined: Sat Nov 27, 2004 3:40 pm
Location: Sweden, Växjö

Beta Networking Howto

Post by Jaix » Mon Dec 27, 2004 12:24 pm

Wouldn´t it be proper with a Beta Networking Howto?

Jaix
Moderator Team
Posts: 838
Joined: Sat Nov 27, 2004 3:40 pm
Location: Sweden, Växjö

Howto Setup A Network Connection

Post by Jaix » Mon Dec 27, 2004 4:32 pm

In the development wiki page there is a Howto page for setting up a network connection, you may try that one, I havn't yet, but it probably will work.

http://mok.lvcm.com/cgi-bin/reactos/ros ... Connection

Merry Christmas and a Happy New Year!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests