Page 3 of 3

Re: Windows 3.11 in NTVDM

Posted: Thu Jun 11, 2015 11:39 am
by EmuandCo
Neither has any other NTVDM of Windows, we don't need it

Re: Windows 3.11 in NTVDM

Posted: Thu Jun 11, 2015 7:30 pm
by Pi_User5

Re: Windows 3.11 in NTVDM

Posted: Sat Jun 13, 2015 11:18 am
by erkinalp
EmuandCo wrote:Neither has any other NTVDM of Windows, we don't need it
Windows 2000/XP/2003 puts stub of DOS bootsector and empty command.com file at upgrade from Windows 98. ReactOS has not got it either.

Re: Windows 3.11 in NTVDM

Posted: Sat Jun 13, 2015 9:18 pm
by hbelusca
It merely dumps the original bootsector from the old installation into a file, and replaces it with NTLDR, and adds an entry in NTLDR menu in order to be able to chainload to Windows 9x. And also, ReactOS doesn't need to be installed on an existing Windows 9x install.

Re: Windows 3.11 in NTVDM

Posted: Fri Aug 28, 2015 10:29 pm
by lumix
is it possible to emulate Windows CE 6?

Re: Windows 3.11 in NTVDM

Posted: Fri Aug 28, 2015 11:31 pm
by Konata
lumix wrote:is it possible to emulate Windows CE 6?
That's far outside the scope of NTVDM. NTVDM is specifically designed to run DOS applications. If you want to run another version of NT then you should probably look into a general-purpose virtual machine.

Re: Windows 3.11 in NTVDM

Posted: Sun Aug 30, 2015 11:43 am
by roytam
lumix wrote:is it possible to emulate Windows CE 6?
It might possible to run CEPC target, but from my testing NTVDM triple faults when switching to CE environment:

Code: Select all

(subsystems/mvdm/ntvdm/ntvdm.c:551)


NTVDM - Starting...


(ntoskrnl/mm/ARM3/pfnlist.c:114) Running low on pages: 80 remaining
(subsystems/mvdm/ntvdm/hardware/cmos.c:462) CMOS opening succeeded (Error: 183)
(subsystems/mvdm/ntvdm/hardware/cmos.c:477) CMOS loading succeeded (Error: 0)
WARNING:  MmLockPageableDataSection at ntoskrnl/mm/ARM3/drvmgmt.c:62 is UNIMPLEMENTED!
(subsystems/mvdm/ntvdm/bios/umamgr.c:517) ROM present @ address 0x000C0000
(subsystems/mvdm/ntvdm/bios/bios32/bios32.c:932) Bda->SoftReset = 0xCCCC ; ShutdownStatus = 0x00
(subsystems/mvdm/ntvdm/bios/vidbios.c:2468) Switching to mode 03h (03h) and clearing the screen; VgaRegisters = 0x0F088080
(subsystems/mvdm/ntvdm/hardware/video/svga.c:1843) Color emulation
(subsystems/mvdm/ntvdm/bios/vidbios.c:2366) HACK: Using HACK for cursor scanlines adjustment
(subsystems/mvdm/ntvdm/hardware/video/svga.c:363) __RegisterConsoleVDM(0)
(subsystems/mvdm/ntvdm/hardware/video/svga.c:363) __RegisterConsoleVDM(1)
(subsystems/mvdm/ntvdm/hardware/video/svga.c:538) (attach) SetConsoleScreenBufferSize(1) succeeded with error 0
(win32ss/user/winsrv/consrv/conoutput.c:1040) SrvSetConsoleWindowInfo(0x00000013, 1, {L0, T0, R79, B24}) called
(subsystems/mvdm/ntvdm/hardware/video/svga.c:540) (attach) SetConsoleWindowInfo succeeded with error 0
(subsystems/mvdm/ntvdm/hardware/video/svga.c:542) (attach) SetConsoleScreenBufferSize(2) succeeded with error 0
(subsystems/mvdm/ntvdm/bios/rom.c:115) Going to run @ address 0x000C0003
(subsystems/mvdm/ntvdm/bios/rom.c:123) ROM @ address 0x000C0000 initialized
(subsystems/mvdm/ntvdm/dos/dos32krnl/process.c:722) Starting 'loadcepc.exe' ('/L:800x600x16 /C:1 CEIMAGE.BIN')...
(subsystems/mvdm/ntvdm/dos/dos32krnl/process.c:635) DosLoadExecutable(0, 'loadcepc.exe', 0x00000000, 0x02C0FDF0, 0x0122AA70)
(subsystems/mvdm/ntvdm/dos/dos32krnl/process.c:300) DosLoadExecutableInternal(0, 0x02C10000, 'C:\loadcepc.exe', 0x00000000, 0x02C0FDF0, 0x0122AA70)
(subsystems/mvdm/ntvdm/dos/dos32krnl/dos.c:560) Setting interrupt 0x00 to 0C10:70EA ...
(subsystems/mvdm/ntvdm/dos/dos32krnl/dos.c:560) Setting interrupt 0x23 to 0C10:9AE2 ...
(subsystems/mvdm/ntvdm/bios/bios32/bios32.c:637) BIOS Function INT 1Ah, AH = 0xB1 NOT IMPLEMENTED
(subsystems/mvdm/ntvdm/dos/dos32krnl/device.c:305) The driver at 00A5:0034 has no associated device node. Installing automagically.
(subsystems/mvdm/ntvdm/bios/vidbios.c:2468) Switching to mode 13h (13h) and clearing the screen; VgaRegisters = 0x0F088280
(subsystems/mvdm/ntvdm/hardware/video/svga.c:1843) Color emulation
(subsystems/mvdm/ntvdm/io.c:325) IoPortProc[0x3D4].IoHandlers.InB already registered
(subsystems/mvdm/ntvdm/io.c:330) IoPortProc[0x3D4].IoHandlers.OutB already registered
(subsystems/mvdm/ntvdm/io.c:325) IoPortProc[0x3D5].IoHandlers.InB already registered
(subsystems/mvdm/ntvdm/io.c:330) IoPortProc[0x3D5].IoHandlers.OutB already registered
(subsystems/mvdm/ntvdm/io.c:325) IoPortProc[0x3DA].IoHandlers.InB already registered
(subsystems/mvdm/ntvdm/io.c:330) IoPortProc[0x3DA].IoHandlers.OutB already registered
(lib/fast486/common.c:566) Fast486ExceptionWithErrorCode(0008:00000013) -- Triple fault
(subsystems/mvdm/ntvdm/bios/bios32/bios32.c:932) Bda->SoftReset = 0x0000 ; ShutdownStatus = 0x00
(subsystems/mvdm/ntvdm/ntvdm.c:269)

NTVDM Subsystem
NTVDM is performing a COLD reboot! The program you are currently testing does not seem to behave correctly! The VDM will shut down...
EDIT: another trial with smaller NK.BIN, and I got this at the end and stalls.
(lib/fast486/extraops.c:309) FAST486 -- Extended opcode 0x09 is UNIMPLEMENTED

Re: Windows 3.11 in NTVDM

Posted: Mon Aug 31, 2015 12:28 am
by hbelusca
roytam wrote:
lumix wrote:is it possible to emulate Windows CE 6?
It might possible to run CEPC target, but from my testing NTVDM triple faults when switching to CE environment:

Code: Select all

(subsystems/mvdm/ntvdm/ntvdm.c:551)


NTVDM - Starting...


(ntoskrnl/mm/ARM3/pfnlist.c:114) Running low on pages: 80 remaining
(subsystems/mvdm/ntvdm/hardware/cmos.c:462) CMOS opening succeeded (Error: 183)
(subsystems/mvdm/ntvdm/hardware/cmos.c:477) CMOS loading succeeded (Error: 0)
WARNING:  MmLockPageableDataSection at ntoskrnl/mm/ARM3/drvmgmt.c:62 is UNIMPLEMENTED!
(subsystems/mvdm/ntvdm/bios/umamgr.c:517) ROM present @ address 0x000C0000
(subsystems/mvdm/ntvdm/bios/bios32/bios32.c:932) Bda->SoftReset = 0xCCCC ; ShutdownStatus = 0x00
(subsystems/mvdm/ntvdm/bios/vidbios.c:2468) Switching to mode 03h (03h) and clearing the screen; VgaRegisters = 0x0F088080
(subsystems/mvdm/ntvdm/hardware/video/svga.c:1843) Color emulation
(subsystems/mvdm/ntvdm/bios/vidbios.c:2366) HACK: Using HACK for cursor scanlines adjustment
(subsystems/mvdm/ntvdm/hardware/video/svga.c:363) __RegisterConsoleVDM(0)
(subsystems/mvdm/ntvdm/hardware/video/svga.c:363) __RegisterConsoleVDM(1)
(subsystems/mvdm/ntvdm/hardware/video/svga.c:538) (attach) SetConsoleScreenBufferSize(1) succeeded with error 0
(win32ss/user/winsrv/consrv/conoutput.c:1040) SrvSetConsoleWindowInfo(0x00000013, 1, {L0, T0, R79, B24}) called
(subsystems/mvdm/ntvdm/hardware/video/svga.c:540) (attach) SetConsoleWindowInfo succeeded with error 0
(subsystems/mvdm/ntvdm/hardware/video/svga.c:542) (attach) SetConsoleScreenBufferSize(2) succeeded with error 0
(subsystems/mvdm/ntvdm/bios/rom.c:115) Going to run @ address 0x000C0003
(subsystems/mvdm/ntvdm/bios/rom.c:123) ROM @ address 0x000C0000 initialized
(subsystems/mvdm/ntvdm/dos/dos32krnl/process.c:722) Starting 'loadcepc.exe' ('/L:800x600x16 /C:1 CEIMAGE.BIN')...
(subsystems/mvdm/ntvdm/dos/dos32krnl/process.c:635) DosLoadExecutable(0, 'loadcepc.exe', 0x00000000, 0x02C0FDF0, 0x0122AA70)
(subsystems/mvdm/ntvdm/dos/dos32krnl/process.c:300) DosLoadExecutableInternal(0, 0x02C10000, 'C:\loadcepc.exe', 0x00000000, 0x02C0FDF0, 0x0122AA70)
(subsystems/mvdm/ntvdm/dos/dos32krnl/dos.c:560) Setting interrupt 0x00 to 0C10:70EA ...
(subsystems/mvdm/ntvdm/dos/dos32krnl/dos.c:560) Setting interrupt 0x23 to 0C10:9AE2 ...
(subsystems/mvdm/ntvdm/bios/bios32/bios32.c:637) BIOS Function INT 1Ah, AH = 0xB1 NOT IMPLEMENTED
(subsystems/mvdm/ntvdm/dos/dos32krnl/device.c:305) The driver at 00A5:0034 has no associated device node. Installing automagically.
(subsystems/mvdm/ntvdm/bios/vidbios.c:2468) Switching to mode 13h (13h) and clearing the screen; VgaRegisters = 0x0F088280
(subsystems/mvdm/ntvdm/hardware/video/svga.c:1843) Color emulation
(subsystems/mvdm/ntvdm/io.c:325) IoPortProc[0x3D4].IoHandlers.InB already registered
(subsystems/mvdm/ntvdm/io.c:330) IoPortProc[0x3D4].IoHandlers.OutB already registered
(subsystems/mvdm/ntvdm/io.c:325) IoPortProc[0x3D5].IoHandlers.InB already registered
(subsystems/mvdm/ntvdm/io.c:330) IoPortProc[0x3D5].IoHandlers.OutB already registered
(subsystems/mvdm/ntvdm/io.c:325) IoPortProc[0x3DA].IoHandlers.InB already registered
(subsystems/mvdm/ntvdm/io.c:330) IoPortProc[0x3DA].IoHandlers.OutB already registered
(lib/fast486/common.c:566) Fast486ExceptionWithErrorCode(0008:00000013) -- Triple fault
(subsystems/mvdm/ntvdm/bios/bios32/bios32.c:932) Bda->SoftReset = 0x0000 ; ShutdownStatus = 0x00
(subsystems/mvdm/ntvdm/ntvdm.c:269)

NTVDM Subsystem
NTVDM is performing a COLD reboot! The program you are currently testing does not seem to behave correctly! The VDM will shut down...
EDIT: another trial with smaller NK.BIN, and I got this at the end and stalls.
(lib/fast486/extraops.c:309) FAST486 -- Extended opcode 0x09 is UNIMPLEMENTED
Hi! Please make a Jira report for this software! :)