0.3.17 testing

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

EmuandCo
Developer
Posts: 4276
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: 0.3.17 testing

Post by EmuandCo » Tue Oct 21, 2014 4:29 pm

OK, assigned it to me.
Image
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: 0.3.17 testing

Post by Black_Fox » Wed Oct 22, 2014 1:44 pm

Zehnvor updated all versions to what's in RAPPS (instead of what's in 0.3.16), additionally he ADDED some apps, contrary to what Z98 requested. Team, please do communicate on this.

Also, the {{JIRA|xxxx}} template is somehow broken since somewhere around ~10 hours ago - it sometimes inserts a newline after it's used and the comments look weird (and take up redundant space) because of it.
EDIT: Another thing that was probably brought in through and update is that whenever I refresh a page, it will say "Your edit was saved".

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: 0.3.17 testing

Post by Z98 » Thu Oct 23, 2014 9:53 pm

I've uploaded another RC that includes fixes intended for LMarble/LBreakout.

http://sourceforge.net/projects/reactos ... p/download

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: 0.3.17 testing

Post by Black_Fox » Thu Oct 23, 2014 10:33 pm

Cool, more green color for the table! Could you please also merge fix for CORE-8665?
EDIT: Also, Adobe's Reader 6 and Reader 7 have regressed since 0.3.16 and 0.3.15 respectively, on the slim chance the issues have slipped under the radar.

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: 0.3.17 testing

Post by Z98 » Thu Oct 23, 2014 10:56 pm

I've pulled in the fix for 8665, but no one currently seems to have time to work on the Adobe related regressions. That said, we do seem to be making fairly good progress with knocking down regressions, hence why this testing before releases is important. There's also been a couple of recent developments that might well make the next release more, interesting, than we originally thought possible.

middings
Posts: 991
Joined: Tue May 07, 2013 9:18 pm
Location: California, USA

Re: 0.3.17 testing

Post by middings » Thu Oct 23, 2014 11:50 pm

Any chance of pulling in Kamil Hornicek's fix for CORE-8547, "NUM Lock LED don't turn on when it's activated"? The num-lock LED is itself a trivial thing but it is noticeable when it doesn't work and makes a bad first impression for the project. (I accept whatever decision the release engineer makes about this.)

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: 0.3.17 testing

Post by Black_Fox » Fri Oct 24, 2014 12:14 am

Z98 wrote:That said, we do seem to be making fairly good progress with knocking down regressions, hence why this testing before releases is important.
Thanks for the merge. I agree it's actually pretty good that the team managed to cut down the regression number so quickly. This release testing fit my schedule since this once I had a few days of free time, also the table motivates for a more structured approach to testing instead of random "and what about this one?".

EmuandCo
Developer
Posts: 4276
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: 0.3.17 testing

Post by EmuandCo » Fri Oct 24, 2014 8:37 am

Sorry, had no time for rapps yet. I WILL do that tomorrow... Work and stuff kept me busy all time that week.
Image
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

kolle_hond
Posts: 17
Joined: Wed Feb 20, 2013 11:29 am

Re: 0.3.17 testing

Post by kolle_hond » Fri Oct 24, 2014 9:52 am

I just want to make sure, is it just me, or is there an issue with the newer versions not showing the selected icon/folder/shortcut? Testing things like copy/paste is quite difficult now :(
I'll start testing the apps in the meantime.

*Update*
Regarding the bug above, it also makes it extremely hard to work with long file names. I have to gamble when picking a VC++ install file and hope it is the correct one.
VC++ 2010 SP1 Redist (at least the installer) is not working:
Image

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: 0.3.17 testing

Post by Black_Fox » Fri Oct 24, 2014 10:42 am

kolle_hond wrote:is there an issue with the newer versions not showing the selected icon/folder/shortcut?
It's not just you, don't worry. A possible workaround is to select by right-click. I you just need to know the filename, then click elsewhere to close the context menu - the filename will stay shown in full length.
Thanks for bringing this up, is there actually a JIRA issue for that?

Forever Winter
Posts: 131
Joined: Sun Oct 20, 2013 6:50 am

Re: 0.3.17 testing

Post by Forever Winter » Fri Oct 24, 2014 11:00 am

The issue at https://jira.reactos.org/browse/CORE-8574 seems to deal with that issue.

Jedi-to-be
Posts: 694
Joined: Sun Mar 16, 2008 11:26 am
Location: Russia, Stavropol
Contact:

Re: 0.3.17 testing

Post by Jedi-to-be » Fri Oct 24, 2014 2:46 pm

Please backport Uniata fixes to 0.3.17

https://jira.reactos.org/browse/CORE-8694

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: 0.3.17 testing

Post by Z98 » Sat Oct 25, 2014 12:03 am

New RC incorporating offbyone browser fix, keyboard lights fix, and an update for uniata up to 45b1. I'd like to ask people to help check and make sure the new uniata version doesn't break anything.

http://sourceforge.net/projects/reactos ... p/download

Webunny
Posts: 1201
Joined: Sat Apr 28, 2012 1:30 pm

Re: 0.3.17 testing

Post by Webunny » Sat Oct 25, 2014 12:05 am

Z98 wrote:New RC incorporating offbyone browser fix, keyboard lights fix, and an update for uniata up to 45b1. I'd like to ask people to help check and make sure the new uniata version doesn't break anything.

http://sourceforge.net/projects/reactos ... p/download
Ok, will do. But it's getting a bit confusing what is/has already been tested with RC1 and/or RC2 and/or RC3 and/or RC4...

Webunny
Posts: 1201
Joined: Sat Apr 28, 2012 1:30 pm

Re: 0.3.17 testing

Post by Webunny » Sat Oct 25, 2014 12:24 am

1)Num lock led works now, for starters. I'll test some other apps out as well.
2)off by one browser still has the flickering and the not viewable buttons.
3)Opera 12.17 still fails

4)Ok, confirmed a regression. I can't install my sounddrivers any more (exe file). I've confirmed that it did/does work with build 61357 (as I remembered it did with all daily builds I tried from that one onwards). When applying the exact same handlings, however, with the RC I get no sound. (which was the case starting with RC1 and up, btw)

Cause and solution may be similar to: https://jira.reactos.org/browse/CORE-7668
Last edited by Webunny on Sun Oct 26, 2014 1:45 pm, edited 1 time in total.

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot] and 1 guest