EPIC WIN!

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

silasqwerty1
Posts: 3
Joined: Mon Aug 21, 2017 9:16 pm

Re: EPIC WIN!

Post by silasqwerty1 » Wed Sep 25, 2019 10:51 pm

Unfortunately I can't figure out how to drag a picture in :p but other than that it seems to work quite well!

blackandwhite
Posts: 3
Joined: Mon Sep 02, 2019 11:21 pm

Re: EPIC WIN!

Post by blackandwhite » Sat Sep 28, 2019 3:23 pm

Illen wrote:
Thu Sep 05, 2019 5:39 pm
You need to load all the needed drivers at boot-time (change the Start value to 0 for each key in HKLM\CurrentControlSet\Services), since NT 4.0 has issues loading them from the ext2 volume. Also change their image path to "system32\drivers\driver_name.sys" (add the ImagePath entry if it doesn't exist), so FreeLDR doesn't fail to load these.
Still getting this error but I've done something wrong probably. Thank you for answer anyway.

Oleg Dubinskij
Posts: 20
Joined: Mon Aug 07, 2017 6:34 pm

Re: EPIC WIN!

Post by Oleg Dubinskij » Wed Nov 06, 2019 8:10 pm

Cool! :D GPU acceleration became working on my real hardware with replaced Win32 subsystem (gdi32.dll, imm32.dll, user32.dll, win32k.sys and winsrv.dll), DirectX API/Graphics drivers (dxapi.sys, dxg.sys and dxgthk.sys) from Win2k3 and full MS DirectX installed (Feb & June 2010, they are avaliable in Rapps)! Without replacing, it doesn't work.
It seems to me that ideally such replacing may "fix" GPU acceleration on all video cards supported by ReactOS (if the driver installs successfully and the system boots with him into desktop). I think I can write a tutorial also, how to do it. ;)
Also it "fixed" all graphical glitches with native driver installed. Now system icons draw fine even with 32-bit colour depth! :)
Font rendering was "fixed" by installing MS Arial fonts from Corefonts.

Screenshot from real hardware:
Image

See video also: https://youtu.be/BzR4ERrf6GM

Configuration of my test PC:

Motherboard: Asus-A7V8X-X;
CPU: AMD Athlon XP 2200+ 1,8 GHz (without SSE2 support);
RAM: 2 GB DDR1 400 MHz;
GPU: ATI Radeon 9600 128 MB vRAM (AGP);
HDD: WDC WD2000JB-00GVC0 (IDE);
CD-ROM: HL-DT-ST DVDRAM GSA-4167B (ATAPI);
Audio: VIA 8235 (AC97);
LAN: VIA Rhine II Fast Ethernet;
WLAN: Dlink DWA-525 Rev A2 (PCI).

What works:

DirectDraw h/w acceleration;
Direct3D 7/8/9 h/w acceleration.
VLC 2.2.8 video playback.

It works with ati2vtag renderer (from the video card driver), even without Mesa3D.
Some games work even better than with our (Wine's) DirectX in VirtualBox.

What doesn't work:

AGP texture accelaration;
OpenGL acceleration (so all OpenGL games doesn't work);
the system not shutdowning properly. For the succesfull shutdown or reboot, you need to press poweroff button on your PC, then wait some time, when desktop will become not clickable, press reboot button, and after this, you can finally turn off the computer, or boot again. However, registry settings save successfully after such "shutdown".

P.S.: Please note that you need to build ReactOS manually with disabled debugging for csrss. For doing this, comment out the following line before building: https://git.reactos.org/?p=reactos.git; ... b=HEAD#l18 Otherwise, the system will not able to boot into desktop with Win32 subsystem files replaced.

gira59
Posts: 1
Joined: Sun Nov 17, 2019 9:02 pm

Re: EPIC WIN!

Post by gira59 » Sun Nov 17, 2019 9:18 pm

hi to all,
I have installed Ros in virtual machine and I nave installed Visual Foxpro 9 developing language.
the application seems to work properly.
Also an .exe compiled with vfp9 is working great.
this is really an epic win!! :D :D :D

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 33 guests