Page 1 of 1

Forum update

Posted: Mon May 26, 2008 1:10 am
by Z98
After a lot of complaining by users about various things, the forum has been updated to phpbb3. Besides a minor problem with integration into the CMS and will be fixed shortly, which by the way doesn't stop anyone from using the forum, we're good to go. With bb3, people posting in the Asian language subforums should be able to use characters in the subject title now. Let us know if that's not the case. Posts from before the upgrade will still look garbled.

Feel free to report any problems you may encounter through one of the project contact methods.

Re: Forum update

Posted: Mon May 26, 2008 6:30 am
by Reacter
Great job guys, once again you pull this off, and nothing happens to the server. I shouldn't say that, but ... ohh well.

Re: Forum update

Posted: Mon May 26, 2008 8:23 am
by Radhad
It looks a bit ugly to me - I cannot see where are new posts or not! Hope you will fix that. Also there is no breadcrumb navi at the top.

Re: Forum update

Posted: Mon May 26, 2008 9:47 am
by preston
good job!

only one things bugs me.. why is the author info on the right side? can't we just follow the crowd and have it on the left side asi it was in the previous version (and as it is everywhere esle)? I don't see any advantages of this new layout it only makes me disoriented :(

Re: Forum update

Posted: Mon May 26, 2008 12:52 pm
by cppm
I take it that the fact it looks completely out of wack with everything else is partly what is meant by "a minor problem with integration with the CMS", i which case I look forward to the forums reacquiring their RosCMS look 'n' feel :P

But that aside.... great work guys :D

Re: Forum update

Posted: Mon May 26, 2008 3:25 pm
by michael79
I really preferred the old forum.

Re: Forum update

Posted: Mon May 26, 2008 5:03 pm
by Z98
There are currently no plans to change the overall style of the board, though I do agree seeing new posts is a bit more difficult now. Breadcrumb navi will be back after I hound Fireball about uploading it. There was a real need to update the forum, since we actually have proper (at least I hope) unicode support now for non-Latin based languages.

Re: Forum update

Posted: Mon May 26, 2008 5:28 pm
by LRN
We do. It's full-scale UTF-8 by default!

Re: Forum update

Posted: Tue May 27, 2008 10:50 am
by fred02
[quote="Radhad"]It looks a bit ugly to me - I cannot see where are new posts or not! Hope you will fix that. Also there is no breadcrumb navi at the top.[/quote]I think I got it: the red icon mean "new posts". (Although personally I think orange would be more appropriate with blue).
[quote="cppm"]I take it that the fact it looks completely out of wack with everything else is partly what is meant by "a minor problem with integration with the CMS"[/quote]It also seems a bit large in current layout.

But aside that, thank for the update, and have high expectation from the new forum once out of the transition period.

Edit: Humm, is the quoting working? And I don't see emoticons and formatting bar when editing. Is it transition period or my configuration?
Also avatars are currently disabled on purpose I guess.

Re: Forum update

Posted: Tue May 27, 2008 7:42 pm
by Colin Finck
BBCode should work again now. This was a bug in the phpBB conversion script.

Yes, avatars and file attachments are currently disabled on purpose.
From what I've heard, most developers prefer if the avatar setting stays disabled and I also don't think it would make sense to enable the attachment feature. Important attachments can go to the Bugzilla.

Best regards,

Colin Finck

Re: Forum update

Posted: Tue May 27, 2008 9:56 pm
by elhoir
another thing i have noticed is that when i click on a link, it does not open a new browser window (or tab when using Firefox or IE >=7), but it uses the current windows to show the target page.

Re: Forum update

Posted: Tue Jun 10, 2008 6:22 am
by Sinister
I haven't checked back in a while (keep hoping for 0.3.5 :wink: ), but I like the new look here. Good work.