Page 1 of 2

0.3.1 Released

Posted: Mon Mar 12, 2007 6:03 am
by Z98
After a long series of delays, 0.3.1 has been released. The various images are all located here.

http://www.reactos.org/en/download.html

Posted: Mon Mar 12, 2007 6:31 am
by GreyGhost
Testing time everyone !!!!

Posted: Mon Mar 12, 2007 12:49 pm
by ROSFan
congratulations developers!
Thanks for the great work!

My "tests":
vmware image:
-Firefox 1.5 runs more stable than ever.
-I got no bluescreens of death
-System tends to nearly freeze in sometimes. After it, it runs again but very slowed down and only a restart helps.
-Abiword doesn't start

CD doesn't work on my hardware.

Posted: Mon Mar 12, 2007 3:42 pm
by walter
i'll try it as soon as possible :D

thanks to everybody made this possible, especially all the devs :)

Posted: Mon Mar 12, 2007 5:52 pm
by RotzKotz_ere
Keep up the good work!
Looking forward... :D

Posted: Mon Mar 12, 2007 6:22 pm
by Sosekoppen
Yippey!!
Tried it in Qemu, and it hangs a bit, but that's because I have AMD Athlon XP, right?

P.S! Started to write an article about ROS on a norwegian site, but it just disappeared when I was about to submit it... :(

Posted: Mon Mar 12, 2007 6:56 pm
by GreatLord
no
if it was u cpu it should not even boot.

the iusse is only affact real hw and vmware workstaions
for amdxp/64

Posted: Mon Mar 12, 2007 9:41 pm
by alfozavr
Hello. Congratulations on the release of the new version! I was amazed by the amount of changes in the Release notes.

Unfortunately, ReactOS 0.3.1 REL live CD didn't boot for me.
Take it into account, that ReactOS 0.3.0 REL live CD did boot on the same PC successfully and I could even run some programms and browse through the system.
But ReactOS 0.3.1 REL live CD boots only until the logo screen. Then my CD-drive just stops reading any data from the CD and nothing happens then.

I wrote both versions to the same CD-RW (certainly finalized the sessions and certainly each time one iso, not both at the same time).

My PC specifications:
ASUS TUSL-2C motherboard, P3 1000MHz CPU, 256mb SDRAM,
ATi Radeon 8500LE 64mb, Creative SB Audigy,
TEAC CD-W524E, Toshiba DVD SD-M1802,
HDD Seagate ST380011A (primary FAT32 partition, secondary NTFS partition),
D-Link DWL-G510 Wi-Fi adapter, Pinnacle PCTV tuner

Posted: Tue Mar 13, 2007 2:28 am
by hto
Tried it in Qemu, and it hangs a bit [...]
There are two known bugs in ReactOS.

1. Do not use KQEMU Accelerator on ReactOS installation.
2. After ReactOS rebooting, close QEMU and then run it again.

Posted: Tue Mar 13, 2007 11:44 am
by qietan
I tried it a few times. Live cd didn't boot, tried it an 2 PCs.
after that i tried to install it.
PC data:
Athlon XP 1200
Nvidia GeForce4 MX 4000
Motherboard EPOX 8RDA3+ (nforce 2 ultra 400 chipset)

but it could not format my HD (there was a fat32 partion on it)

after that i formated it under win98 with PQmagic to fat, but wenn i tried to install it hang up when it tries to copy data on HD :-( what can i do?

i was waiting for it so long

Posted: Tue Mar 13, 2007 7:09 pm
by ixrayi
It can be a Problem with the MBR !
I have used for this Problem Active@Kill Disk. A Hard Drive Eraser. Low Level Format.


If that was the Problem please write.

Posted: Tue Mar 13, 2007 7:30 pm
by Z98
I'm actually somewhat surprised you got so far on an AMD XP machine. There's a known problem with those because of unimplemented trap code.

0.31 live CD fails to boot

Posted: Wed Mar 14, 2007 8:46 am
by barker
Same problem here as the others,
live CD gets to splash screen and then halts. No more data being read from the drive.
Tried on 2 different machines - one with AMD Duron, one with Intel P3.

Nice splash screen though ;-)

barker

Installation on HD fails

Posted: Wed Mar 14, 2007 10:11 pm
by fritz.mueller
I tried to install Reactos 0.3.1 on a 4 GB HD on a AMD System 2800 MHz, MSI K7N2Delta mainboard, 1 GB RAM. It also hangs after the reactos logo. The interesting fact (which I will test once again) is that on standard systems like windows the kernel is the first file on the FAT partition (it is on one of the first
physical sectors) whereas on reactos it seems to be anywhere in the middle (tested with encase - will make one more test). And if the kernel is not loaded correct, nothing will work. Maybe an equivalent of this could be the bug on the CD too.

Vmware virtual machine also fails to boot

Posted: Thu Mar 15, 2007 2:49 pm
by barker
after failing on a couple of machines with the liveCD I installed VMware player and tried the vmware edition.
Same result - splash screen then nothing.

No messages so hard to know what's wrong.

barker