VIA C3 EDEN 533

Обсуждаем ReactOS по-русски

Moderators: fog, fireball

Post Reply
doleynikov
Posts: 4
Joined: Wed Dec 18, 2019 9:09 am

VIA C3 EDEN 533

Post by doleynikov »

Приветствую!
Пробовал установить на маленький тонкий клиент вместо нелицензионной XP. не получилось! начинает грузиться и кажет черный экран.
Есть возможность собрать REACTOS чтобы работало на моем железе? Подскажите, можно уйти от ХРюши? Линух тоже не каждый собирается на это железо.

User avatar
binarymaster
Posts: 356
Joined: Sun Nov 16, 2014 7:05 pm
Location: Russia, Moscow
Contact:

Re: VIA C3 EDEN 533

Post by binarymaster »

ReactOS ещё рано куда-либо устанавливать и пользоваться на серьёзе. Система всё ещё в альфе.

Если на вашем железе есть последовательный COM порт, можно попытаться выяснить, что идёт не так.

doleynikov
Posts: 4
Joined: Wed Dec 18, 2019 9:09 am

Re: VIA C3 EDEN 533

Post by doleynikov »

ага! можно через COM посмотреть логи? консоль? или постоянный вывод в порт?

Start
Posts: 157
Joined: Sun May 16, 2010 5:59 pm

Re: VIA C3 EDEN 533

Post by Start »

Debugging
Можно выбрать вариант загрузки с выводом на экран и сфотографировать, можно использовать reactos-livecd сборки.
После сообщения kdb:> набрать bt и нажать Enter,
после следующего сообщения kdb:> набрать x esp L 160 и нажать Enter.

kdb:> bt
kdb:> x esp L 160

Релизы быстро устаревают, поэтому лучше тестировать "Ночные сборки" или свежие релиз-кандидаты, когда они появляются.

Отправка отчетов

Jedi-to-be
Posts: 699
Joined: Sun Mar 16, 2008 11:26 am
Location: Russia, Stavropol
Contact:

Re: VIA C3 EDEN 533

Post by Jedi-to-be »

В зависимости от сложности проблемы можно заставить работать. Но нам нужна от вас информация.


Лучше сначала попробовать не установку, а запуск LiveCD

doleynikov
Posts: 4
Joined: Wed Dec 18, 2019 9:09 am

Re: VIA C3 EDEN 533

Post by doleynikov »

Наконец-то удалось вернуться к этой проблеме (не прошло и года!) пробую свежий Live-CD. При попытке запуска по умолчанию - синий экран с предложением повторить, а потом проверить на вирусы итд. Сейчас пробую запуск с Debug - похоже зависла. На экране последняя строка указывает на
multy(0)disk(0)rdisk(0)pfrtition(1)\reactos\System32\Drivers\SWENUM.SYS
Вот только XP пишет , что проц не EDEN а Samuel 2. Может поможете запустить ReactOS на этом античном железе?
вот ссылки на экран отладчика:
https://yadi.sk/i/YRVTP1laQlEu-A
https://yadi.sk/i/a_h9HTxWzK25EA
https://yadi.sk/i/nl8fetx4YAgE0g
Last edited by doleynikov on Fri Jun 26, 2020 3:08 pm, edited 2 times in total.

User avatar
binarymaster
Posts: 356
Joined: Sun Nov 16, 2014 7:05 pm
Location: Russia, Moscow
Contact:

Re: VIA C3 EDEN 533

Post by binarymaster »

doleynikov wrote:
Fri Jun 26, 2020 2:12 pm
Наконец-то удалось вернуться к этой проблеме (не прошло и года!) пробую свежий Live-CD. При попытке запуска по умолчанию - синий экран с предложением повторить, а потом проверить на вирусы итд. Сейчас пробую запуск с Debug - похоже зависла.

https://yadi.sk/i/YRVTP1laQlEu-A
IopMarkBootPartition последняя функция в стеке перед bug check, система не распознала дисковый контроллер, и поэтому не может нормально загрузиться с CD или HDD.

Если на вашей машине достаточно памяти, можно загрузить через RAM диск.

doleynikov
Posts: 4
Joined: Wed Dec 18, 2019 9:09 am

Re: VIA C3 EDEN 533

Post by doleynikov »

256мегабайт это достаточно? и как это сделать? вообще странно. Я пробовал и к IDE CDROM подключать и с USB флешки - не получается

и, да, я гружусь с флешки!

doleynikov
Posts: 4
Joined: Wed Dec 18, 2019 9:09 am

Re: VIA C3 EDEN 533

Post by doleynikov »

Похоже, нет загрузки с флешки. жаль. Другого способа грузиться нет. подождем. Пока пиратствовать будем

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest