Search found 21 matches

by Zero3K
Mon May 18, 2020 5:19 pm
Forum: Development Help
Topic: Issue with an audio driver
Replies: 3
Views: 302

Re: Issue with an audio driver

I am attaching some logs that might help pinpoint the issue.
by Zero3K
Mon May 11, 2020 7:19 pm
Forum: Development Help
Topic: Issue with an audio driver
Replies: 3
Views: 302

Re: Issue with an audio driver

I tested it in a Windows Server 2003 VM and a Windows 7 VM. In a Windows Server 2003, playing audio results in a hang for a couple of minutes and then a noise is heard. In a Windows 7 VM, playing the audio test found in the Advanced tab of the Speakers Properties results in no hang but the button sh...
by Zero3K
Mon May 11, 2020 6:08 pm
Forum: Development Help
Topic: Issue with an audio driver
Replies: 3
Views: 302

Issue with an audio driver

I am having an issue regarding an audio driver that is written in C++. The issue is that its not playing any audio (or instead plays a short static noise) in a Windows Server 2003 VM ran using VirtualBox with the type of sound card being emulated set to AC97. The debug logs are available at https://...
by Zero3K
Sun Apr 19, 2020 11:13 pm
Forum: General Discussion and Feedback
Topic: SwiftShader 3.2 nologo for ReactOS
Replies: 4
Views: 4523

Re: SwiftShader 3.2 nologo for ReactOS

Someone should make a new build of it to see if it speeds up the FPS of games any. I get more FPS with the wined3d from the official site + Mesa3D in ROSAPPS + Microsoft's DirectX 9.0c than with your build of SwiftShader + Microsoft's DirectX 9.0c.
by Zero3K
Mon Sep 30, 2019 1:51 am
Forum: Support
Topic: How to Install Virtual Box Guest Additions
Replies: 15
Views: 2939

Re: How to Install Virtual Box Guest Additions

Are you trying to dual boot boot ReactOS and install the Guest Additions when booted from it?
by Zero3K
Mon Sep 30, 2019 1:44 am
Forum: Support
Topic: I want to support, but first I need to know if I can...
Replies: 6
Views: 1839

Re: I want to support, but first I need to know if I can...

I am going to say that the answer to all questions you have is a NO. It is WAAAAAAYYYYY too soon for it to be sold on devices.
by Zero3K
Thu Sep 26, 2019 2:18 am
Forum: News
Topic: ReactOS 0.4.12 released
Replies: 9
Views: 10342

Re: ReactOS 0.4.12 released

Whatever you feel like trying.
by Zero3K
Thu Sep 26, 2019 2:10 am
Forum: Development Help
Topic: Help needed with getting the AC97 driver sample to compile
Replies: 0
Views: 4741

Help needed with getting the AC97 driver sample to compile

I have managed to get Oleg Dubinsiky to work on getting it to compile via ROSBE. He wasn't able to fix the remainder of them. You can see the PR with the work that was done to get it compiling by going to https://github.com/Zero3K/reactos/pull/1.
by Zero3K
Fri Jan 18, 2019 8:03 pm
Forum: Support
Topic: Mouse and keyboard don't work (Install CD)
Replies: 28
Views: 15793

Re: Mouse and keyboard don't work (Install CD)

I will try that soon and let you know if it works.

EDIT: I've already tried that and reported my findings at https://jira.reactos.org/browse/CORE-15 ... ent-110807.
by Zero3K
Fri Jan 18, 2019 7:08 pm
Forum: Support
Topic: Mouse and keyboard don't work (Install CD)
Replies: 28
Views: 15793

Re: Mouse and keyboard don't work (Install CD)

Huh? Are you stating that I should replace usbport.sys and usbehci.sys that are on the Boot CD with the ones from Windows XP in order for it to work properly?
by Zero3K
Fri Jan 18, 2019 6:02 pm
Forum: Support
Topic: Mouse and keyboard don't work (Install CD)
Replies: 28
Views: 15793

Re: Mouse and keyboard don't work (Install CD)

For the hanging when detecting the USB devices, I replaced usbport.sys when it was installed on a Macbook which gets the keyboard and mouse to work in the 2nd-stage setup. When I replaced it in the boot CD, it tells me that it can't load usbuhci.sys and then freezes at a black screen after I press E...
by Zero3K
Mon Dec 31, 2018 12:13 am
Forum: Support
Topic: VGAL Liveusb no display
Replies: 4
Views: 2494

Re: VGAL Liveusb no display

Same here (but on a Macbook). I blacklisted the troublesome USB devices and it still happens unless I rename usbhub.sys.
by Zero3K
Sat Dec 01, 2018 4:02 am
Forum: Development Help
Topic: Build failing when enabing _WINKD_
Replies: 3
Views: 745

Re: Build failing when enabing _WINKD_

That makes sense.
by Zero3K
Sat Dec 01, 2018 3:50 am
Forum: Development Help
Topic: Build failing when enabing _WINKD_
Replies: 3
Views: 745

Build failing when enabing _WINKD_

When I enable _WINKD_ by adding it as a parameter in ROSBE via the configure.cmd, ninja bootcd eventually fails with the following error shown in https://pastebin.com/PLd1JQzG. How do I fix it so that it can continue being built?
by Zero3K
Fri Nov 30, 2018 8:43 pm
Forum: Support
Topic: RamDisk Boot Option
Replies: 15
Views: 9681

Re: RamDisk Boot Option

Either that or ERAM, which is available at https://github.com/Zero3K/ERAM.