Search found 25 matches

by hzlilx
Tue Aug 14, 2012 6:57 pm
Forum: Support
Topic: Mouse can't work on VBox
Replies: 8
Views: 6546

Re: Mouse can't work on VBox

It seems the ROS can't find my HID mouse at all, therefore, it certanly can't act on mouse moving. I use "device manager" under windows xp to see the connection of device tree, it shows: ACPI Multiprocessor PC, ROOT\ACPI_HAL\0000 Microsoft ACPI-compliant System, ACPI_HAL\PNP0C08\0 PCI Bus, ACPI\PNP0...
by hzlilx
Thu Aug 09, 2012 5:44 pm
Forum: Support
Topic: Mouse can't work on VBox
Replies: 8
Views: 6546

Re: Mouse can't work on VBox

I burned the livecd in a cdrw-disk, then test it in real hardware. The good news is, the livecd can work, it boot to destop success. The bad news is, the mouse can't work, no matter that changed or not changed that two files.

It need more time to find what cause the matter.
by hzlilx
Tue Aug 07, 2012 1:45 pm
Forum: Support
Topic: Mouse can't work on VBox
Replies: 8
Views: 6546

Re: Mouse can't work on VBox

Pisarz wrote:Just disable USB mouse emulation in VBox and it should work actually.
Thank you, but maybe somebody can fix this problem.
by hzlilx
Mon Aug 06, 2012 3:17 pm
Forum: Support
Topic: Mouse can't work on VBox
Replies: 8
Views: 6546

Re: Mouse can't work on VBox

Bug 7227 reported, please check. Now I surprise to find, after I modified the two files(reactos\reactos\lib\drivers\hidparser\api.c, reactos\reactos\win32ss\user\ntuser\mouse.c), I can also respond mouse left click and right click. I remember mouse left click and right click couldn't work yesterday ...
by hzlilx
Sun Aug 05, 2012 6:13 pm
Forum: Support
Topic: Mouse can't work on VBox
Replies: 8
Views: 6546

Re: Mouse can't work on VBox

Further information, mouse can't work correctly on VBox only for HidUsb mouse driver, on this condition, you can delete hidclass.sys/hidparse.sys/hidsub.sys from livecd.iso, which is in subdirectory reactos\system32\driver, to let mouse work on legacy mouse driver, and it will run well.
by hzlilx
Sun Aug 05, 2012 1:58 pm
Forum: Support
Topic: Mouse can't work on VBox
Replies: 8
Views: 6546

Mouse can't work on VBox

My computer is ASUS i7 notebook pc, I test the newest trunk version on qemu and vbox, qemu seems to work well, but vbox, the mouse can't work. I find the reason is that ros can't get mouse position correct, on the file reactos\reactos\win32ss\user\ntuser\mouse.c, line 189/190 show me ptCursor.x/ptCu...
by hzlilx
Sat May 07, 2011 1:22 am
Forum: General Discussion and Feedback
Topic: freeldr can be chainloaded by Grub4DOS
Replies: 18
Views: 12235

Re: freeldr can be chainloaded by Grub4DOS

It is very often to use grub4dos to boot cdrom or usb disk or iso image. It can bring us a lot of other benifits.
by hzlilx
Mon Apr 25, 2011 5:07 pm
Forum: General Discussion and Feedback
Topic: [TESTING] Developer request: UNIATA
Replies: 23
Views: 14626

Re: [TESTING] Developer request: UNIATA

I think my way is not the right way. I am doing some work, trying to make it clear, but it is very hardware specify, I think it may beyond my ability.
by hzlilx
Mon Apr 25, 2011 2:07 pm
Forum: General Discussion and Feedback
Topic: [TESTING] Developer request: UNIATA
Replies: 23
Views: 14626

Re: [TESTING] Developer request: UNIATA

I burn the iso to cd but it can't boot. I read FAQ it tell me SATA cd driver is not surpport, maybe this is the reason. so, I make a grub4dos bootable usb disk, and use grub to boot livecd iso file. The livecd iso file boot start success, load uniata.sys and other xxxx.sys ok, but, it print "try in...
by hzlilx
Wed Apr 20, 2011 4:38 pm
Forum: General Discussion and Feedback
Topic: [TESTING] Developer request: UNIATA
Replies: 23
Views: 14626

Re: [TESTING] Developer request: UNIATA

I burn the iso to cd but it can't boot. I read FAQ it tell me SATA cd driver is not surpport, maybe this is the reason. so, I make a grub4dos bootable usb disk, and use grub to boot livecd iso file. The livecd iso file boot start success, load uniata.sys and other xxxx.sys ok, but, it print "try ini...
by hzlilx
Sat Apr 16, 2011 2:01 pm
Forum: General Discussion and Feedback
Topic: [TESTING] Developer request: UNIATA
Replies: 23
Views: 14626

Re: [TESTING] Developer request: UNIATA

Also ask how to configue the virtual machine to use sata disks.

I downloaded the iso file and burn it to my cd-data-disk, but sadly after reboot my notebook pc it can't boot up at all, it seemed it can't be regarded as a bootable cd-data-disk.
by hzlilx
Tue Mar 01, 2011 2:57 pm
Forum: Support
Topic: Archetypal Error of "EnableUserModePnpManager() failed!"
Replies: 28
Views: 14421

Re: Archetypal Error of "EnableUserModePnpManager() failed!"

PlugPlay service is created twice, one is from base\system\services\rpcserver.c:2867, the other is from base\system\services\database.c:1182. (base\system\services\database.c:1182) 2. CurrentService = 006564F0, name = EventLog (base\system\services\database.c:1048) ScmStartService() called, Service ...
by hzlilx
Tue Mar 01, 2011 2:00 pm
Forum: Support
Topic: Archetypal Error of "EnableUserModePnpManager() failed!"
Replies: 28
Views: 14421

Re:

Why??? Yeah, It is really a matter. when I modifed the code as below, it boot ok, and mouse work! Now I am looking for what is happen. static DWORD ScmStartUserModeService(PSERVICE Service, DWORD argc, LPWSTR *argv) { RTL_QUERY_REGISTRY_TABLE QueryTable[3]; PROCESS_INFORMATION ProcessInformation; S...
by hzlilx
Mon Feb 28, 2011 10:36 pm
Forum: Support
Topic: Archetypal Error of "EnableUserModePnpManager() failed!"
Replies: 28
Views: 14421

Re: Archetypal Error of "EnableUserModePnpManager() failed!"

qemu + livecd, test result: svn 50912: random boot crash, if boot ok, the mouse work well. svn 50912 + modifed \base\system\services\[services.c, services.h, database.c]: boot well and fast (seem too fast), but when gone to deskto, mouse can't work! svn 50917's test result may be error(due to not fu...
by hzlilx
Mon Feb 28, 2011 4:36 pm
Forum: Support
Topic: Archetypal Error of "EnableUserModePnpManager() failed!"
Replies: 28
Views: 14421

Re:

hto wrote:> the mouse could't work, I can't find mouse at all.

Please check if PlugPlay is not started.
I rolled back to svn 50917 version, the mouse still couldn't work, so I need more time to find out what is the matter.