[ros-dev] Re: [ros-svn] [gdalsnes]
18113:-reorderInsertXscendingOrder macro argument order and
crashfourit at gmail.com
Wed Sep 28 17:51:15 CEST 2005
However an large function can also ramper readability and mantainiblility. I
think the best thing is to evaluate on how to write a function on a case by
On 9/28/05, Thomas Weidenmueller <w3seek at reactos.com> wrote:
> Casper Hornstrup wrote:
> >>The alternative is: do the cleanup at every return, use goto or use
> >>1)Cleanup at every return is madness. Most functions in ros do a large
> >>amount of cleanup at each return and I sometimes spot mistakes where
> >>one/more return misses some cleanup. Those errors are _hard_ to find.
> > The functions are too large then. Use more smaller functions instead.
> I agree with Nathan. Having tons of small functions often isn't a good
> solution, especially when you'd have to create dozens of small helper
> functions. That not just only generates slower code but also makes it
> more difficult to get a picture of the algorithm used. I much more
> prefer jumping to cleanup labels the way Nathan demonstrated it. Of
> course I avoid it where it doesn't make sense.
> - Thomas
> Ros-dev mailing list
> Ros-dev at reactos.com
<P>My DeviantArt.com page: <A href="http://crashfourit.deviantart.com/">
http://crashfourit.deviantart.com/</A><BR>My FanFiction.net bio page: <A
http://www.fanfiction.net/u/726606/</A><BR>My Blog: <A href="
Debate: <A href="http://www.americasdebate.com/">
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Ros-dev