Back to Website

Testing 0.0.17 in VMWARE

Ask your support questions in here

Moderator: Moderator Team

Testing 0.0.17 in VMWARE

Postby claude.lebrun » Wed Sep 13, 2017 3:13 pm

Hi,

I have been redirrected to the forum from JIRA, to ask about how to make ReactOS 0.0.17 works in a version of XP i have in VMWare, here is the screenshot https://imgur.com/a/gadd9

In fact i want to make a tutorial (i don't know if it's the right channel to discuss this here)

Thank you for taking time to answer

be sure it's not urgent but a tutorial that i want to make on my yt channel https://www.youtube.com/watch?v=lMkQ8_XYl10&list=PLhAVPXwuphwnbUAoj4XHIHT96bgylvN4t

Best regards
Last edited by claude.lebrun on Wed Oct 04, 2017 3:56 pm, edited 2 times in total.
claude.lebrun
 
Posts: 8
Joined: Mon Jul 24, 2017 3:30 pm


Re: Testing 0.0.17 in VMWARE

Postby oldman » Wed Sep 13, 2017 5:51 pm

claude.lebrun wrote:Hi,
I have been redirected to the forum from JIRA, to ask about how to make ReactOS 0.0.17 work in a version of XP I have in VMWare

I remember that the early versions of ReactOS were installed into an existing Windows OS. I installed it into Windows 95 and it installed to C:\reactos. The installation created a boot floppy to run it instead of the installed Windows OS. If the boot floppy was in the drive, you booted into ReactOS, but if the boot floppy was not in the drive, then the computer booted into the installed Windows OS.

So you will have to acquire a copy of Windows 9x to install into your VM, then you can install ReactOS into the Windows 9x. I am not 100% sure now how you ran the installation, I think it must have run as a normal execute within Windows 9x and you created a boot floppy to boot it instead of Windows (as stated above).

Is this of any help to you?
You can keep your Virtual Machines - I test in real hardware!
Please keep the Windows classic (9x/2000) look and feel.
[url=https://www.reactos.org/wiki/User:Oldman]A layman's guide[/url] - debugging - bug reporting - compiling.
oldman
 
Posts: 888
Joined: Sun Dec 20, 2009 1:23 pm

Re: Testing 0.0.17 in VMWARE

Postby claude.lebrun » Wed Sep 13, 2017 5:58 pm

Yes very good, so the version is more likely to work with Win 95 excellent i have to test it to see how it's going

Of course i've openend an issue on JIRA about the boot.asm that asks for the floppy disk (see here https://imgur.com/a/Opmab) if we can continue the discussion about it here it would be nice (i've created a repo for this subject on github https://github.com/claudelebrun/xOS) perhaps it should be better to open a thread specially for this other case

anyway, the more important to me is to have something on youtube to explain what i am doing (am working on it)

Thank you very much

@dizt3mp3r 0.4.6 is also something i am working on ;)
claude.lebrun
 
Posts: 8
Joined: Mon Jul 24, 2017 3:30 pm

Re: Testing 0.0.17 in VMWARE

Postby oldman » Wed Sep 13, 2017 6:53 pm

claude.lebrun wrote:........... if we can continue the discussion about it here it would be nice ............

Please do not expect much help from me, I am only a user and abuser of operating systems; I am no developer! And do not expect much of the early versions of ReactOS; all you are going to see, is a blue screen (blue.sys) and some text on screen. The text was much smaller than you get with DOS and it impressed me at the time.

There were a few test apps; the two that I remember were, helloworld.exe and winhelloworld.exe.
You can keep your Virtual Machines - I test in real hardware!
Please keep the Windows classic (9x/2000) look and feel.
[url=https://www.reactos.org/wiki/User:Oldman]A layman's guide[/url] - debugging - bug reporting - compiling.
oldman
 
Posts: 888
Joined: Sun Dec 20, 2009 1:23 pm

Re: Testing 0.0.17 in VMWARE

Postby claude.lebrun » Thu Sep 14, 2017 11:40 pm

thank you @oldman i hope i'll be making it work again and make a tutorial for that so i am searching for an image of win95 for now
keep in touch
claude.lebrun
 
Posts: 8
Joined: Mon Jul 24, 2017 3:30 pm

Re: Testing 0.0.17 in VMWARE

Postby oldman » Fri Sep 15, 2017 10:12 am

I have now down loaded release 0.0.17 and unpacked it; I do not now recognise it! It looks like that you unpack it to C: and then run C:\reactos\boot.bat.

I have had a thought, why not run it from DOS!

I have an old computer that is running Windows ME, so I think I will copy the reactos folder to it's C: drive and see what boot.bat does.
You can keep your Virtual Machines - I test in real hardware!
Please keep the Windows classic (9x/2000) look and feel.
[url=https://www.reactos.org/wiki/User:Oldman]A layman's guide[/url] - debugging - bug reporting - compiling.
oldman
 
Posts: 888
Joined: Sun Dec 20, 2009 1:23 pm

Re: Testing 0.0.17 in VMWARE

Postby claude.lebrun » Fri Sep 15, 2017 3:49 pm

that's excellent testing i am still searching for a version of win95, nothing yet in fact boot.bat does that link i've shared when we compile it
claude.lebrun
 
Posts: 8
Joined: Mon Jul 24, 2017 3:30 pm

Re: Testing 0.0.17 in VMWARE

Postby oldman » Fri Sep 15, 2017 4:53 pm

I have tried to run boot.bat in Windows ME, but it says that it needs to be run in real DOS mode, which ME does not support. I cannot remember the key to press to get it to boot into DOS, so I abandoned trying with Windows ME.

I then installed freedos into a VirtualBox virtual machine, then copied the folder reactos to freedos drive C: and ran boot.bat, then got error code.

I think that you had to down load a separate floppy boot image (it's a long time ago now and the memory is faint). So the problem will be, how to make it boot.

boot.bat contains one line
Code: Select all
loadros ntoskrnl.exe ide.sys vfatfs.sys

loadros ............ MS-DOS Application.
ntoskrnl.exe .. Application.
ide.sys ............. System file.
vfatfs.sys ........ System file.

loadros has this message at the end of it's file Error: Bad DOS EXE magic

So it must start in DOS.
You can keep your Virtual Machines - I test in real hardware!
Please keep the Windows classic (9x/2000) look and feel.
[url=https://www.reactos.org/wiki/User:Oldman]A layman's guide[/url] - debugging - bug reporting - compiling.
oldman
 
Posts: 888
Joined: Sun Dec 20, 2009 1:23 pm

Re: Testing 0.0.17 in VMWARE

Postby claude.lebrun » Fri Sep 15, 2017 5:46 pm

i ve just found a windows 95 the installation in virtualbox is complicated i am trying to install it https://imgur.com/a/BOraa but you gave me an idea is to test it on Dos
so i've found the images here : http://www.le-grenier-informatique.fr/pages/les-documents-du-grenier/les-systemes-os-microsoft-1.html (win 95b zip pass : legrenierinformatique)

So yes i've seen that line thank you to make it clear, it's that file loadros that i want to understand how it is copiled and how it is used to boot, so nice we are on the right way
claude.lebrun
 
Posts: 8
Joined: Mon Jul 24, 2017 3:30 pm

Re: Testing 0.0.17 in VMWARE

Postby oldman » Sun Sep 17, 2017 4:31 pm

I have now replaced Windows ME with Windows 98 and run ReactOS after re-starting in DOS mode. I just ran boot.bat in DOS mode and ReactOS started, but I ended up with a Page Fault and did not get to the command prompt!

So it looks like it is later releases that required a boot floppy to run.
You can keep your Virtual Machines - I test in real hardware!
Please keep the Windows classic (9x/2000) look and feel.
[url=https://www.reactos.org/wiki/User:Oldman]A layman's guide[/url] - debugging - bug reporting - compiling.
oldman
 
Posts: 888
Joined: Sun Dec 20, 2009 1:23 pm

Re: Testing 0.0.17 in VMWARE

Postby florian » Sun Sep 17, 2017 9:16 pm

Please, could the topic be moved from Tutorials to Support?
Thanks in advance.
florian
 
Posts: 410
Joined: Tue Nov 01, 2005 2:19 am
Location: Germany

Re: Testing 0.0.17 in VMWARE

Postby claude.lebrun » Wed Oct 04, 2017 3:52 pm

Hi, i am back to the devs,
how it's going ?

So restarting from the begining let's continue here please viewtopic.php?f=4&t=16681
claude.lebrun
 
Posts: 8
Joined: Mon Jul 24, 2017 3:30 pm


Return to Support

Who is online

Users browsing this forum: No registered users and 10 guests